Automated follow-up comments for Pending tickets (public or internal)

5 Comentários

  • Kevin

    Great stuff! This has been a thorn in my side for a long time. I'm having some challenges implementing though:

    1. The URL target is not working when i visit it directly, but the test says 'message successfully sent'. When I visit the URL, I receive a message - {"error":"InvalidEndpoint","description":"Not found"}. When I remove everything after 'tickets', I do not get the error. 

    2. For the authentication, the target test is only a success when I use my Zendesk login credentials, not the TOKEN. And it is only a success when I leave the full {{ticket.id}}.json?ticket[comment][public]=true on the target URL.

    3. When following the steps for "Auto Solving Pending Ticket" I get this error:

    Automation could not be updated as:

    • Automation must not run multiple times per ticket: It must have a time based condition that is only true once (Hours since created is 24) or a action that nullified a condition ("Priority Is High" and an action setting it to "Priority Is Urgent").

    When I add an action such as 'updating ticket status' via the Zendesk options, the error goes away.



    0
  • Kevin

    As an update, adding 'Ticket Tags doesn't contain = solve_ticket' to the conditions corrected my #3 issue above.

    0
  • Jay Hogan

    Good catch Kevin.  I noticed a couple of omissions and since updated step 4 in my overview to include the following:

    • >> Set it to meet all of the following conditions:
      *Ticket Tags contains none of the following = solve_ticket
    • >> Set it to perform these actions:
      *Ticket Status = Solved

    Regarding point 1 in your post, I never tried browsing directly to the URL in the target but when I submitted "Test Target" and it worked, I moved on to the next steps.  Can you elaborate why you are trying to browse to the URL? 

    For the 2nd point in your post, I just realised that I left out a key instruction in step 2 which I have since updated (I left out the "/token" when specifying the username):

    • *Basic Authentication > Username = username from Step 1 followed by "/token" (e.g. email@somedomain.com/token)

    Hopefully the above will get this working for you.  Sorry for the omissions.

    0
  • Kevin

    Thanks for the update Jay! 

    Disregard my point 1. The ticket commenting works in the method you described. I just assumed you would be able to reach the target URL, and because I couldn't, thought it would not fire correctly. Not the case. Everything works great!

    As for the authentication information, I currently have it working using my Zendesk login. Not sure if both methods are applicable, but everything is automating for me. 

    Thanks again for this great tip!

    0
  • Serge Payette

    Really cool stuff Jay, thanks for sharing.

    0

Publicação fechada para comentários.

Desenvolvido por Zendesk