Contact Us and Chat Widgets enabled simultaneously

Respondida

18 Comentários

  • Brett Bowser
    Zendesk Community Team

    Hey David,

    While it's not a supported workflow, you could get your chat account key using the instructions provided in the link I attached. You'll copy that account key over and replace the Support account key from your web-widget code snippet.

    One code snippet will contain your Support account key while the other contains your Chat account key.

    I hope this points you in the right direction!

    0
  • David

    Hi Brett,

    Thanks for the suggestion. I have tried it but unfortunately it either doesn't work or I have done something incorrectly.

    I have got my Chat Account Key easily enough, and COPY and PASTED the key after the "key=" element in the Widget Code.

    So that effectively I have two Widget Codes, one with the Live Chat Key, and one with the Contact Us Key.

    But when I add both scripts to my Magento 1 site via the usual manner, the Contact Us one still doesn't appear. And the Live Chat one no longer allows the Visitor to Select Department.

    Any ideas?

    Dave

    0
  • Brett Bowser
    Zendesk Community Team

    Hey David,

    Is your Magento site public at all? If so, could you provide a link so we can take a look at your website?

    You'll also want to double-check and make sure you have the Contact Form enabled under your widget customization page by navigating to Admin>Channels>Widget. Chat should be toggled off under this setting as well since you're using a separate widget.

    I'd recommend checking that you've set up the placement of these widgets so they're not stacked on top of each other which I've seen happen in the past as well.

    Keep me posted!

    0
  • David

    Hey Brett,

     

    I have done as you have suggested but I am not sure this fix will work.

    I currently have it enabled but it is now just overlaps two lots of Contact Us Forms and no Live Chat.

    I have left it enabled so you can see the results. https://www.isub-supplies.co.uk/

    I will attach screenshots of my settings to show my work.

    (For the purpose of the screenshots I replaced the Keys with text just in case I shouldn't be sharing the code)

    Thanks for your help

    Dave

    1
  • Brett Bowser
    Zendesk Community Team

    Thanks David,

    I'm going to bring this into a ticket for our Customer Advocacy team to see what expected behavior is here.

    You'll receive a follow-up email shortly stating your ticket has been created.

    Cheers!

    0
  • David

    Hi Brett,

    I am coming back to this as unfortunately I cannot get any assistance from Zendesk as we only have the Essential Plan in place so will not provide any guidance or support.

    I don't suppose you or anyone else has any suggestions on whether this can be overcome?

    It may be that I have to cancel Zendesk Chat and just use the Contact Us for and a third party Chat Widget instead.

    Cheers

    Dave

    0
  • Thomas Verschoren
    Community Moderator

    Hey,

     

    Since the migration of Zendesk Chat from Zopim running both is not an option anymore.

     

    You can however get the same experience with a bit of custom widget code just below the default code:

    <script type="text/javascript">
    window.zESettings = {
       "webWidget": {
          "contactOptions": {
             "enabled": true
          }
       }
    }
    </script>

    This will show users an option list when they open the widget instead of having one or the other:

    Choose Chat (if agents are online) or use the Web Form

     

    1
  • David

    Hi there,

    Do I need to edit this script in any way? I have just tried copy and pasting it into the Misc Scrips section of my Magento 1 website and no options appear at all?

     

    Is there something else I need to do to enable this?

    Cheers

    Dave

    0
  • Thomas Verschoren
    Community Moderator

    Hey,

    From what I saw in your original screenshot you have disabled Chat in the Zendesk Support widget.

    This should be enabled in order for the option to appear.

    Also, make sure at least one agent is online. Otherwise Zendesk will resort to only showing the contact form.

    0
  • David

    Ok sorry I must still be missing something here. This is the Widget Script I have entered now:

    <!-- Start of isub Zendesk Widget script -->
    <script id="ze-snippet" src="https://static.zdassets.com/ekr/snippet.js?key=(I have removed the key)"> </script>
    <script type="text/javascript">
    window.zESettings = {
    "webWidget": {
    "contactOptions": {
    "enabled": true
    }
    }
    }
    </script>
    <!-- End of isub Zendesk Widget script -->

     

    I've ensured the Contact Form and Chat is enabled and there is an Agent Online as well:

    But this is the results I get:

     

    Only Live Chat showing. What am I doing wrong please?

     

    Thanks for your help

     

    Dave

    0
  • Dan Ross
    Community Moderator

    Hey David,

     

    It looks like you're nesting <script> tags inside the script for the zendesk widget.

     

    Try this:

    <!-- Start of isub Zendesk Widget script -->
    <script id="ze-snippet" src="https://static.zdassets.com/ekr/snippet.js?key=(I have removed the key)"> </script>
    <!-- End of isub Zendesk Widget script -->


    <!-- Configure the the Zendesk Widget with additional settings -->
    <script type="text/javascript">
    window.zESettings = {
    "webWidget": {
    "contactOptions": {
    "enabled": true
    }
    }
    }
    </script>
    <!-- End configuration the the Zendesk Widget with additional settings -->
    0
  • David

    Thanks Dan,

    OK I have tried that and sadly still no success.

    Effectively just Copy and Pasted what you have done into my Magento 1 Miscellaneous Scripts but obviously with the key= added back in:

    <!-- Start of isub Zendesk Widget script -->
    <script id="ze-snippet" src="https://static.zdassets.com/ekr/snippet.js?key=(Removed Key)"> </script>
    <!-- End of isub Zendesk Widget script -->


    <!-- Configure the the Zendesk Widget with additional settings -->
    <script type="text/javascript">
    window.zESettings = {
    "webWidget": {
    "contactOptions": {
    "enabled": true
    }
    }
    }
    </script>
    <!-- End configuration the the Zendesk Widget with additional settings -->

     

    I saved the config and refreshed the cache of my browser: https://isub-supplies.co.uk

    Chat and Contact Form both enabled in Zendesk and Agent Online ready for the Chat.

    It sounds like this is possible just odd that something seems to be holding me back? Anything else I could check?

    It would make me a very happy fella to get this resolved...

    Cheers

    Dave

    0
  • Dan Ross
    Community Moderator

    Hey David,

    I just tested out the script above with my widget and it seems to work fine and displays contact options correctly. I'm not sure what could be conflicting and am not really getting much out of the console when viewing your site. I skimmed through the sources of your page but couldn't find the actual scripts themselves to what the site is actually loading/running. 

    Can you try pasting the script and your widget on an HTML testing site, like this one and see if it works?

    If it does, it may be a magento specific issue. If not, then I'd check and make sure you've got everything copy pasted properly.  Here's an example of it working with my widget on the above site. 

     

    0
  • Thomas Verschoren
    Community Moderator

    Hey

    It seems you have two widget codes embedded in your source code. This confuses the setup and  so the code only applies two one of them, resulting in the falure:

    0
  • David

    Hi Dan and Thomas,

     

    OK this sounds good what you have both have provided me so I think we may be narrowing down the issue.

     

    I have copy and pasted the text from my widget code into the w3schools link to confirm that somewhere / somehow mine isn't working still but not sure why:

    There is only one line of code in my Magento Admin Settings.

    0
  • Rivera Lee

    That worked for me! Thanks!

    1
  • Omni Factors (EMEA reseller)

    Hi all,

    I was trying to sort contact options to first display contact form then live chat but I can’t get it.
    Is there a way to achieve this?

    0
  • Kay
    Community Moderator

    Hi Ilhan,

    you can set-up a pre-chat form via Settings > Widget > Forms > Pre-chat form.
    The options for configuration are limited.

    If you are referring to the Ticket form, it's not possible to set that as a first step in the Web Widget at the moment. However if you need absolute 100% control you could completely customize via the Web SDK.

    0

Por favor, entrar para comentar.

Powered by Zendesk