Zendesk Secure Settings Proxy Error

11 Comentários

  • Eric Nelson
    Zendesk Developer Advocacy
    Hey Kate,

    Tough to say based on the info we have. Are you experiencing this when serving the app from local during development?

    Thanks!
    0
  • Kate Culver

    Hi Eric,

    Yes I'm experiencing it while running the app locally using:

    zat server --app-id=

    with our app id & then entering our private API key when prompted by:

    Enter a value for optional parameter 'lomi_api_private_api_token' or press 'Return' to skip:

    Is the Zendesk proxy adding headers to the request?

    0
  • Eric Nelson
    Zendesk Developer Advocacy
    Hey Kate, 
     
    Zat can't actually handle secure parameters when running the app locally. We talk about it here and here, I'd suggest installing the app as a private application and see if you still run into the issue. 

    Thanks!
    0
  • Dinesh Korgaokar

    Hello Kate,

    can you try cors: true option in request for making  cross-origin HTTP requests 

    Thanks,

    0
  • Kate Culver

    Eric Nelson That explains a lot! I hadn't come across that yet, thank you!
    That's a bit frustrating that we have to deploy in order to test but that unblocks me!

     

    Dinesh Korgaokar cors: true can't be used with Zendesk Secure Settings because it cors: true bypasses the Zendesk Proxy which is what injects the Secure Setting.

    0
  • Brian Reynolds

    I am having this same problem. Were you able to resolve it? It seems like the error is on the Zendesk proxy server, not the external API server.

    0
  • Eric Nelson
    Zendesk Developer Advocacy
    Hey Brian, 

    Are you experiencing this when testing from locally while using secure settings like Kate?
    0
  • Brian Reynolds

    Hi Eric,

    No, I had noticed from the documentation that secure parameters cannot work through the ZCLI testing method, so this was after uploading to our environment.

    Thank you,

    Brian

    0
  • Eric Nelson
    Zendesk Developer Advocacy
    Hey Brian,

    Would you mind if we open up a ticket so that you can share your application with us?

    Thanks!
    0
  • Brian Reynolds

    Hi Eric,

    Figured it out! The domainWhitelist in the manifest was incorrect. I had only added "domain.com" and it requires "subdomain.domain.com." That one change fixed it.

    Thank you,

    Brian

    0
  • Eric Nelson
    Zendesk Developer Advocacy
    Glad to hear you got it sorted? Let us know if you need anything else.
    0

Por favor, entrar para comentar.

Powered by Zendesk