Salesforce error: "Unable to create Salesforce PushTopic"

Return to top

11 Comments

  • Fred Thomas

    I am receiving a similar error just for the Contact sync "Unable to update Salesforce PushTopic. Review Salesforce API settings."

    I have verified settings, in fact, it was once functional but now will not allow me to re-enable. Org and ticket sync are enabled and functioning. Any steps to try for this particular message?

    0
  • Dwight Bussman
    Zendesk Customer Care

    HeyO @...

    There's a few reasons this could be happening. The fastest way to determine the cause of this would likely be on a screen-sharing session. I'll take a look to see if you've already got a ticket on this matter and get one started if you don't yet have one.

    0
  • Christopher Wooten

    @... I am running into the same issue. My count in SF shows as 7. How many are needed for just the account to org sync?

    0
  • Dwight Bussman
    Zendesk Customer Care

    HeyO @...

    It looks like you're already working with someone on this matter within a ticket. If there are findings from that ticket that have a broader application, we can post them here after it's been resolved.

    1
  • Maik Künnemann

    Hi Dwight Bussman, we have the same problem as here:

    https://support.zendesk.com/hc/en-us/articles/4408830295066/comments/4408849081370

    Reconnection is not possible. Do you have a solution?

    0
  • Dwight Bussman
    Zendesk Customer Care

    Hi Maik Künnemann

    This will likely require a ticket with our Support Team to look more closely into this matter. Please contact support to start that process. Please reference this thread when you reach out so we have all the relevant information to get started.

    0
  • Ken Jon Tarnate

    Hi, 

    How can I solved the issue regarding on unable to read salesforce push topic?

    0
  • Dwight Bussman
    Zendesk Customer Care

    HeyO Ken Jon Tarnate

    This issue can be caused by a few different factors. If the steps listed in this article aren't helping to resolve this, I recommend reaching out to our support team so that we can take a closer look at your specific case.

    0
  • Nicole Robertson

    This may hopefully help someone.

    I have been battling this problem for months now and just realised that the field I was using as a condition in my sync filtering filter was a look up field, which the Zendesk Integration doesn't support.

    It wasn't immediately obvious that it was a lookup field (I'd thought it was a pick list) so If you are still having trouble with this I would suggest looking through the fields you want to use one by one to make sure they are all supported types. 

    Here is the part in the configuration guide where it specifies which field types can be used. 

    0
  • Dwight Bussman
    Zendesk Customer Care

    Good callout. Thanks Nicole! 

    0
  • Ran Geller

    I was able to get it fixed by disconnecting and reconnecting the Salesforce integration.

    It is frustrating that the integration breaks from time to time, and I am not getting any notification about it.

    1

Please sign in to leave a comment.

Powered by Zendesk