Back up your Help Center articles at the click of a button!

219 Comments

  • Rune Jherd Matas

    I just want to back up a category in our help center. Any way to specify that?

    Thank you.

    0
  • Felix Stubner

    @...

    There's no way to specify only a specific category. kBackup doesn't support granularity in that regard.

    0
  • DonnaJ

    Just wanted to add my thanks for a great tool. We have SSO and so Felix pointed out that I'd have to have a non-SSO login. Once I got that kBackup worked like a charm. We have (for now) a pretty simple configuration, so I just needed to get "Help Center" and not worry about anything else. But over 800 articles and 8200+ images all on my desktop now (well in a "Backup..." folder) so I can cull articles and images.

    Thanks!

    Donna

    0
  • Felix Stubner

    @... thanks for your feedback, glad kBackup could help!

    0
  • JACQUELINE LEHR

    Hi Felix,

    I just used this tool for the first time, and it has positively made my day! An image folder! YAY! Thank you so much!

    0
  • Felix Stubner

    @... that's great to hear. I am glad that kBackup could help you :)

    0
  • Marci Abraham

    Hi @... this looks like a great concept I have two questions:

    1) do you have a Mac version yet?

    2) about the security check for the user being in the Zendesk domain: does this allow only admin-level users to create a backup, or would it also be possible for an end user with a login to do it?

    0
  • Felix Stubner

    @... Thanks for reaching out.

    1) Not at this time. I am considering building a cross-platform version on a different tech stack though, but nothing concrete at this time. If Mac is your only option, there are some free software available that will let you run Windows programs such as Wine.

    2) The app simply checks whether a user account exists within the Zendesk domain. If it does, it will pull any articles that the account has access to. 

    Hope that helps to answer your questions. Let me know if there's anything else.

    0
  • Finaleサポート

    @... I had a trouble with the download but it's solved by using sub-domain as you suggested. Thank you very much for your quick and kind support! 

    0
  • Felix Stubner

    @... No problem at all, glad I could help!

    0
  • DonnaJ

    @...: Can you tell me how the file names that I get running kBackup are derived?

    The article files often have "..." so I'm guessing that you're chopping the name at some point. What can you tell me about the image files? They can have ridiculously long names and do not seem to cut off the names like is done with the .HTML files.

    How do these names relate to what Zendesk is actually storing?

    Thanks,

    Donna

    0
  • Felix Stubner

    Hey, @... thanks for reaching out.

    Regarding the "..." that is correct. I am chopping the names as in some cases I encountered issues that resulted in the file path of the saved file being too long for windows to do anything with.

    For images, I saved them as is as that is their actual file name as presented in the URL. In a later rework, I intended to generate the HTML output files to include the images. So it's primarily to retain the original file name. Articles don't technically have a file name so I could generate one during the backup.

    So the HTML files use the Article's ID. That is the bolded part in this URL https://support.zendesk.com/hc/en-us/articles/203690806-Using-views-to-manage-ticket-workflow.

    For images, these are stored in an images subdirectory in the format of <article_id>_<filename_of_the_file_in_url>. I chose this format to relate the images to a particular article so that it's easier to understand which images belong to which article.

    I hope that sheds some light on your queries.

    0
  • Jack Yumulu

    Hi @...,

    This is exactly what I need :) and hoping you can help with an issue at the sign-in window.

    I am an Admin in Zendesk.

    When I try to login it complains about the password.

    I'm presuming it's because our passwords are managed on a third-party system which we used to sign in i.e. Google.  

     

    0
  • Felix Stubner

    Hi @...,

    Thanks for reaching out. I have received reports from other users of similar issues. It is likely due to external authentication being used.

    I am working on a patch at the moment that would allow users to use an API Token instead but am running into some trouble with Windows SmartScreen. It's blocking my app as I haven't typically signed it with a code-signing certificate. I am still trying to find a solution to this as code-signing certificates can be quite costly. Please feel free to email me directly at felix.stubner(at)gmail(dot)com and I can send you the preview build.

    0
  • Samantha Chavez

    @... This tool literally saved me so much time. You really deserve tacos for life!

    1
  • Felix Stubner

    @... very glad to hear that kBackup was able to help! :)

    0
  • David Cochrane

    Hi@... Im having the same issue with the error saying the username or password is incorrect. Im the account owner, and we dont use any external party for authentication. Could you help please?

    0
  • Felix Stubner

    Hi, David Cochrane thanks for reaching out. I've gone ahead and responded to your email. Feel free to follow up with me on that.

    0
  • David Cochrane

    Thanks very much for your help Felix - all sorted. Much appreciated.

    1
  • Mitali Runwal

     I'm having the same issue with the error saying the username or password is incorrect. I'm the account owner, and we don't use any external party for authentication. Could you help please?

    0
  • Felix Stubner

    Hi Mitali Runwal thanks for giving kBackup a try. I'm sorry to hear that you're running into an issue. The good news is that I have been working on a new build that allows you to use a username and API key combination. Please reach out to me at felix(dot)stubner(at)gmail(dot)com and I can share it with you. Alternatively, I plan to update this page over the weekend with this latest build, so you'll be able to download it through this page then.

    0
  • Olivier Degardin

    Hi Felix Stubner.

    Using the great kBackup with Zendesk for February 2021.

    Unfortunately, for the 16th of February 2022, I've got an issue. The backup is blocked/crashed after around 10-15 minutes (the total duration of the backup was around 35-40 minutes before the issue). Message = "The general exception was hit: StartIndex can't be inferior to zero. Setting Name = StartIndex". See screenshot. Any idea?

    Thanks.

    0
  • Felix Stubner

    Hi Olivier Degardin,

    Thanks for reaching out and giving kBackup a try. I'll need to investigate this issue further. There should be a number of log files created in the root directory of the backup. Please zip these and send them to me at felix(dot)stubner(at)gmail(dot)com. I'd be happy to take a closer look then.

    I look forward to hearing from you.

    1
  • Olivier Degardin

    Felix Stubner:  you're a genius!  Your very new version of kBackup is wonderful: you should suggest it here.  It fixed my issue. It allows to save multiple languages platforms. THANK YOU VERY MUCH. Very appreciated.

    2
  • Felix Stubner

    You are very welcome Olivier Degardin and thank you for working with me to find a solution to the issue. I hope to share this new version with everyone soon, but first, a little more testing ;) 

    3
  • Максим Кремлёв

    The tool seems to work, but it only downloads about 1/4 of our articles.  admin rights are all there

    0
  • Felix Stubner

    Hi Максим Кремлёв, thanks for reaching out! Could you share with me a screenshot of the application after you have started a backup? You can email me at felix(dot)stubner(at)gmail(dot)com and I'll be happy to take a look.

    0
  • Janaina

    Hi Felix Stubner 
    I'm having some problems extracting the articles. My knowledge base has 10,000 articles. When I use the app, only 6 articles are extracted, always the same articles and the title appears incomplete.

    domain: prosoftbr

    Could you help me?

    0
  • Felix Stubner

    Hi Janaina, thanks for reaching out! That's definitely quite curious, I'd love to take a look and see why it's happening. I tried to visit your domain but it appears I cannot create an account. Please reach out to me at felix(dot)stubner(at)gmail(dot)com and I can share a debug build with you that will provide me with more information. It also includes some other features and fixes that may already address the issue. I look forward to hearing from you!

    0
  • Marc Spaeth

    Hello,

    I am trying to backup my entire help center articles within includes about 14 languages.  When I used the tool it only exports the English. I tried changing my language to one of the languages and refreshing the page but when I try the export i still only get the articles in English.

    Is there a way to do the export that I get all the articles for all the languages?

    Thanks in advance.

    Marc

    0

Please sign in to leave a comment.

Powered by Zendesk