Formatting "Description shown to end users

Answered

13 Comments

  • Andrew J
    Community Moderator

    Have you tried adding a break tag
    where you want the breaks?
    Also, you show one below the box, and one in the box, is that something you are trying to achieve?

    0
  • Loic Bouvet

    I want this format on my first screen : 

     

    Explanation for approvers (* mandatory if purchase for Project or special request):

    Purpose of resource usage :

    Expected result of resource usage :

    Details on resource usage :

    Reason of resource usage :

    Estimated duration of use:

     

    But I have this one (without breaks between each part): 

     

    Explanation for approvers (* mandatory if purchase for Project or special request): Purpose of resource usage : Expected result of resource usage : Details on resource usage : Reason of resource usage : Estimated duration of use:

     

    I tried to add <br> on the ticket fields but doesn't work : 

    This is what you mean ? 

     

    Do you have any idea ? 

    0
  • Loic Bouvet

    Hello,

     

    I worked with a developer, 

    I changed the CSS : 

    #request_custom_fields_360014941759_hint{     white-space: pre !important; }

    And that's OK

     

    You can close the ticket

    1
  • Ben Van Iten
    Zendesk Digital Resources Team

    Hi Ioic,

    Thanks for the update! I was going to also propose that you make each of those lines into its own custom fields so you can capture the customer's response to each individually but it sounds like you've got it all figured out :)

    Have a great day!

    0
  • Greg Vowles

    Can someone explain where to go to update the CSS so that it adds carriage returns? I want to add carriage returns in for the "Type" field, in the Description to show to end users on the submission page:

    i.e. I want the Description to show to end users to show:

    Question: e.g. “How do I change my default homepage?”.

    Incident: e.g. “I can’t access X”.

    Problem: e.g. “Nobody in my office can access the system”.

    Task: an action that needs to be carried out by an agent, to resolve the ticket.

    instead of:

    Question: e.g. “How do I change my default homepage?”. Incident: e.g. “I can’t access X”. Problem: e.g. “Nobody in my office can access the system”. Task: an action that needs to be carried out by an agent, to resolve the ticket.

    3
  • Patrick Dang

    Hi @Ioic, I now have encountered the same issue/question, how do I set a line breaker between sentences in the "Description shown to end users". 

    I don't understand your comments above - can you please explain or show me how to set the line breaker?  thanks so much

     

    "...I worked with a developer, 

    I changed the CSS : 

    #request_custom_fields_360014941759_hint{     white-space: pre !important; }

    3
  • Terry Dawson

    Hi. I wanted a global solution to this problem, rather than a field specific one.

    I've modified the CSS to apply the same white-space hint to all paragraphs (<p>) inside to request-forms. Someone may know some good reason why this is a bad idea. Please tell me if you do!

    I did the following:

    • Navigate into Guide Admin
    • Select Customize Theme from sidebar
    • Choose 'Customize' on the theme you wish to modify (Ours is based on Copenhagen, your situation may be different. Stop here if anything fails from here onward)
    • Select 'Edit Code' (bottom right)
    • Scroll down and select 'style.css' from the sidebar
    • use the Find feature to search for the string '.request-form textarea'
    • Underneath that clause add:
    • /***** My Request Form Customization *****/
      .request-form p {
      white-space: pre !important;
      }
    • Hit 'Publish'

    It will apply this change to every form field description, which was what I wanted.

    So far it seems to be working as intended.

     

    1
  • Dave Dyson
    Thanks for sharing your solution, Terry -- and welcome to the community!
    0
  • Sarosh Dholoo

    Edit: If anyone's wondering how to configure this per field when using the Selway template (as Terry Dawson's great steps only work for Copenhagen), see below.

    I'd recommend making a copy of the current Theme and Previewing the changes before applying to your Production theme.

    • Navigate into Guide Admin
    • Select Customize Theme from sidebar
    • Choose 'Customize' on the theme you wish to modify.
    • Select 'Edit Code' (bottom right)
    • Scroll down and select 'style.css' from the sidebar
    • Add the following, with the highlighted the Field ID: 
    #request_custom_fields_5384261552785_hint {
    white-space: pre !important;
    }
    • Hit Save and Preview
    • Once satisfied with the changes, apply them your Production Theme and Publish

     

    Result:

     

    1
  • Eddy H

    Sarosh Dholoo, you said this works for Copenhagen, is there a version for the US on this? I’m having the same issue and couldn't figure it out. I just want this on a specific field we have. Thanks!

    0
  • Sarosh Dholoo

    Eddy H Copenhagen is just the name of the theme, it's not based on your geolocation.

    My steps are per field specifically for the Selway theme as that's what we use, whereas Terry's were for the Copenhagen theme for all fields. Each template will have its own settings and yours may have the sections outlined in Terry's steps or it may not. Selway did not so we're doing it per field. Example:

     

    1
  • Eddy H

    Thank you so much, Sarosh! This is working for me now! 

    1
  • Noelle Cheng

    Sarosh Dholoo  I tried to implement what you stated but it's not working. In the Description hint field I tried breaking the line and also adding the break tag but my description hint is still not reflecting the line breaks.

     

    0

Please sign in to leave a comment.

Powered by Zendesk