iOS Chat SDK v2 greeting words not appearing when all fields are fulfilled.

12 Commentaires

  • Greg Katechis
    Zendesk Developer Advocacy

    Hi Bing! Please check to see if this issue is present in our sample apps. If you are still seeing this issue, drop me a line here.

    0
  • bing wen

    @...

    Sorry, I'm using iOS version, can you give me the iOS sample? By the way I checked the android sample, it works fine.

    0
  • Greg Katechis
    Zendesk Developer Advocacy

    I'm sorry for sending the wrong one...here are the iOS demo apps!

    0
  • bing wen

    Thanks, @...,

    I've tested in this demo and I found it's happening in the demo too,

    there are two issues:

    1. The greeting words not appearing when all visitor info is fulfilled.

    2. Message sending is laggy when I send multiple messages at a time.

    Please help to find out why... thanks

    0
  • bing wen

    @... Is there any update?

    0
  • Omer Baskurt

    Having the same issue with the latest SDK. Seems like it's still not fixed. Is there any update on this or a workaround?

    0
  • Shakti

    Hi Greg-Katechis!, We are also facing the same issue. How can we solve this?

    0
  • Greg Katechis
    Zendesk Developer Advocacy

    Hi all, apologies for missing responses here. The behavior that is noted is expected and correct in iOS, as we note in our documentation here. Since the information is already being passed in the chatAPIConfig, there's no need for AB to prompt for that. 

    0
  • Shakti

    Yes but in our case, if all the information is passed in the chatAPIConfig, greeting words stop coming and a blank chat gets opened. Is this an expected behaviour? if yes, is there any workaround so that a user starting a new chat is always greeted even if all the information is preset using chatAPIConfig?

    1
  • Adam Rowe

    I'm having this same issue. We don't need the AB to prompt the user to fill in the information, just... something and not a blank screen. The only solution I've currently found is to pass in the phone number of the user as nil to get the bot to say "Hi. What can we help you with today?".

    Otherwise, it's a blank screen and looks like a broken experience.

    2
  • Kevin Kim

    Also having the same issue with authenticated users.  Hoping for an update/fix on this soon. 

    2
  • Marc Renaud

    We have the same issue on our side.  Greg-Katechis, can you give an updated answer to mention if there is a work around?

    Currently the user sees a blank chat view.  It would be nice to have a message to prompt the user to type something in order to be added to the queue.

    i.e. "Hello, how may I help you?"

    Is there a way to do this when the the user info has been pre-filled?

    0

Vous devez vous connecter pour laisser un commentaire.

Réalisé par Zendesk