問題の内容
チケットを更新すると、次のエラーメッセージが表示されます。
チケット番号____は保存されていません。更新が保存されたときにこのチケットに変更が行われました。もう一度試してください。
原因
これはコリジョンエラーです。コリジョンエラーは、2つ以上の更新が同時にチケットを変更しようとする際に発生します。更新コリジョンが発生すると、中断が起き、ワークフローに重大な問題が発生する可能性があります。
エージェントに対しこのエラーメッセージが表示された場合、エージェントが更新した直前に他の操作によってチケットが更新されたことになります。2つの更新が競合しそうになっていたため、Zendeskが停止しました。エージェントは更新を再送信する必要があります。
エージェントの更新と同時に行われた場合は、常に更新によりこのエラーが発生する可能性があります。よくある原因は次のとおりです。
- 別のエージェントが同じチケットを開き、独自の更新を送信する。
- エージェントがチケットの更新を送信するのと同時に、外部のサービスがAPIコールを使用してチケットを更新する。
- インストール済みアプリが更新を送信した場合。
- エージェントがチケットを更新する際、チケットに対して自動化が起動した場合。
- Talkコールの終了時にコール録音が追加された場合。
- チャットまたはメッセージングの会話の終了時にチャットの会話ログが追加された場合。
- サイドカンバセーションが作成または更新された場合。
メモ:自身の更新のトリガが競合する可能性はありません。ただし、他の更新が同時に行われた場合にもトリガが起動する可能性があります。つまり、トリガがコリジョンエラーに関係している可能性があっても、コリジョンエラーを引き起こすことはできません。
解決のステップ
アクティブなアカウントでこのエラーが時々発生するのは普通です。更新コリジョンは、あらゆる発生源によりいつでも発生します。
ただし、このエラーが頻繁に発生する場合は、ワークフローに問題がある可能性があります。最初のステップは、更新コリジョンの発生源を特定することです。
- エラーが表示されたら、チケットに戻り、チケットのイベントを確認します
- ほぼ同時に行われた他の更新を探します
- より多くの例を収集し、パターンを探します
パターンを特定できたら、ワークフローを調整して更新コリジョンを最小限に抑えます。ワークフローはそれぞれで異なります。
- チケットイベントログを確認して、エージェントと同時にチケットが更新された原因を確認します。
- アプリまたはAPIスクリプトが不要な更新を大量に作成する場合は、設定の変更や無効化を検討します。
- 複数のエージェントが同時に同じチケットを頻繁に更新する場合、エージェントコリジョンの問題が発生する可能性があります。詳細については、次の記事を参照してください:「Playモードでのエージェントコリジョンのトラブルシューティング」
- サイドカンバセーションを開始してからチケットが更新されるまで少し待つように、エージェントにアドバイスします。
- エージェントに、コール録音または会話の会話ログが表示されてから、Talk、Chat、メッセージングのチケットを更新するようにアドバイスします。
- チケットが作成された直後に適用されるルーティングルールと自動更新を確認します。これらは、自身でチケットを作成したり、新規のカスタマーチケットをすばやく開いたりするエージェントに影響を与える可能性があります。
- 10秒待ってから、再度更新を送信します。