Add pop up text on yes and no vote buttons in Help Centre

回答済み

7 コメント

  • Ifra Saqlain
    Community Moderator
    Most Engaged Community Member - 2022
    Most Engaged Community Member of The Year - 2021

    HEy Anton Van der meyden, you didn't close the double quotes in the article page code:

     

    It should be closed:

     

     

    Team

    0
  • Anton Van der meyden

    Ifra Saqlain

    Hello,

    Thank you for your help.

    I have updated this but still have the same issue. I have my CSS at the bottom of the style.css

    When I click the pop up still does not work.

    Can you please assist?

    Thank you.

    Kind Regards,

    Anton

     

    0
  • Ifra Saqlain
    Community Moderator
    Most Engaged Community Member - 2022
    Most Engaged Community Member of The Year - 2021

    Okay, remove the inline CSS from your <article ...> tag,

    Current:-

    <article id="main-content" class="article" style="background-color: #F5F8FB; border: 1px solid purple; margin: 20px; border-radius: 10px; padding: 10px 10px 10px 10px;" >

     

    After:-

    <article id="main-content" class="article">

     

     

    Output:

     

    if still you're getting issue then share the URL here so I can figure it out.

     

    0
  • Anton Van der meyden

    Ifra Saqlain

    Thank you for your help. This resolved the issue.

    Can you assist me with one more query, please?

    I would like to remove the sign-in button completely to all users.

    My script for my header is below. I also 


    <a class="skip-navigation" tabindex="1" href="#main-content">{{t 'skip_navigation' }}</a>

    <header class="header">
      <div class="logo">
        {{#link 'help_center'}}
          <a href="https://www.hellocasino.com/"><img src="{{settings.logo}}" alt="{{t 'home_page' name=help_center.name}}">
        {{/link}}
      </div>
      
            <right><p><font size="4"><font color="white"><< <b>{{dc 'help_cente-back_to_hello_casino'}}</b> </font></font><p></right>


      <div class="nav-wrapper">
        <button class="menu-button" aria-controls="user-nav" aria-expanded="false" aria-label="{{t 'toggle_navigation'}}">
          <svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" focusable="false" viewBox="0 0 16 16" class="icon-menu">
            <path fill="none" stroke="currentColor" stroke-linecap="round" d="M1.5 3.5h13m-13 4h13m-13 4h13"/>
          </svg>
        </button>
        
        
        <nav class="user-nav" id="user-nav">
         
        </nav>
        {{#if signed_in}}
          
            <div class="dropdown-menu" role="menu">
              {{link "my_activities" role="menuitem"}}
              {{my_profile role="menuitem"}}
              {{change_password role="menuitem"}}
              {{link "sign_out" role="menuitem"}}
            </div>
          </div>
        {{else}}
          {{#link "sign_in" class="sign-in"}}
            {{t 'sign_in'}}
          {{/link}}
        {{/if}}
      </div>
        
            
    </header>

    I did remove the below but when I active my Help Centre it comes back but whenI preview as an end user it is gone. Is there something I am missing that makes appear?

     

     <nav class="user-nav" id="user-nav">
         
        </nav>
        {{#if signed_in}}
          
            <div class="dropdown-menu" role="menu">
              {{link "my_activities" role="menuitem"}}
              {{my_profile role="menuitem"}}
              {{change_password role="menuitem"}}
              {{link "sign_out" role="menuitem"}}
            </div>
          </div>
        {{else}}
          {{#link "sign_in" class="sign-in"}}
            {{t 'sign_in'}}
          {{/link}}
        {{/if}}
      </div>

    Thank you.

    Kind Regards,

    Anton

     

    0
  • Anton Van der meyden

    Ifra Saqlain

    So it is Annoymus users it still appears to.

    Thank you.

    Kind Regards,

    Anton

    0
  • Ifra Saqlain
    Community Moderator
    Most Engaged Community Member - 2022
    Most Engaged Community Member of The Year - 2021

    Anton Van der meyden, I think the header code is not correct, share the URL of your HC I want to see myself.

     

    I applied your header code to the fresh Copenhagen Theme and got the UI of the header:

    0
  • Anton Van der meyden

    Ifra Saqlain

    I have adjusted my code and it works as intended now.

    Thank you for your help.

    Kind Regards,

    Anton

    0

サインインしてコメントを残してください。

Powered by Zendesk