Trying to Post using the APIs

3 コメント

  • Tipene Hughes
    Zendesk Developer Advocacy
    Hey Rafi,
     
    Everything looks good with the request. Can you double check that the URL you're sending the request to matches the help center brand that you're wanting to move the article under?
     
    Feel free to reach out with any questions!
     
    Tipene
    0
  • Quinn McHugh

    Hi Rafi Syed,

    Did you happen to figure out your issue?

    I'm getting the same error using zenpy and have verified the section, user_segment_id, and permission_group_id are valid, per the create article section in the Zendesk API Reference.

    zenpy.lib.exception.RecordNotFoundException: {"error": "RecordNotFound", "description": "Not found"}

    Edit: I created a new issue in zenpy here: https://github.com/facetoe/zenpy/issues/527

    0
  • Christopher Mc

    I had the same issue and after troubleshooting it looks like op had the same root cause:

    "user_segment_id": "null"

    should be

    "user_segment_id": null

    (no quotation marks around null)

    This fixed it for me straight away

    0

サインインしてコメントを残してください。

Powered by Zendesk