How to resolve accounts that fail to sync from Salesforce to Zendesk

Return to top
Have more questions? Submit a request

5 Comments

  • Adam Reid

    Hi Dwight Bussman

    We've just recently connected our Salesforce sandbox to our Zendesk Sandbox, and we're experiencing issues where the integration is syncing one or two accounts we test but will not sync other accounts we create.

    The accounts that have synced work and we're able to push all updates from Salesforce to Zendesk when mapped fields are updated from Salesforce.

    Are there any known issues where the integration is only syncing some Salesforce accounts and not others?

    We've followed all the documentation to create this integration and are confused to why it's not working as expected.

    0
  • Dwight Bussman
    Zendesk team member

    Hi Adam,

    I see you've reached out to our Support team already which is definitely the right move here. There are a few reasons this might happen. The external_id conflict described in this article is just one of the potential conflicts. It may be worthwhile for me to expand this article to include some of the other frequent causes of this issue.

    0
  • Adam Reid

    Dwight Bussman 

    As mentioned in your comment on our ticket, it was the mapping from domain name to domain that caused the break as we still had (http://) on the domain in Salesforce, stripping that out to just have the apex domain fixed it.

    1
  • Russell Smith

    It would be very helpful. I have setup the sync for Orgs-Accounts also and whatever is misconfigured or failing is completely opaque. Nothing in the Integration Logs on Zendesk side. The integration isn't using any special fields per se. It's matching criteria is simply Account Name (SF) to Name (ZD). Mapping fields are Account Name (SF) to Name (ZD) and an additional text field I added to my Salesforce Account object called "sf2zd" (SF) which maps to a corresponding field called "SF Test Account" (ZD). As far as I can tell all of the settings related to permissions are set in SF. And here I sit with no idea what is actually failing. Help is appreciated. I have submitted a support request as well from this same email.

    0
  • Dwight Bussman
    Zendesk team member

    HeyO Russell,

    That definitely sounds like a misbehavior to me, and one into which we'll want to take a closer look. I'll check in with that ticket you raised to see where it's at and that someone responds to you shortly. If there's a more general bit of information raised in that investigation which seems relevant to the group, I'll be sure to share the gist back to this thread.

    0

Please sign in to leave a comment.

Powered by Zendesk