Table Cell Padding in GUIDE

Answered

10 Comments

  • Stephen Kairys

    To clarify: the display problem illustrated in the main question is in PREVIEW mode. I do see whitespace to the left in EDIT mode. Thanks again.

    0
  • Ifra Saqlain
    Community Moderator
    Most Engaged Community Member of The Year - 2021

    Hey, you can add cell padding in pixel (20px) and I hope your query would be resolve :) and to see the result - go to the preview mode.

    Thanks

    0
  • Stephen Kairys

    Hi Ifra, thanks for your response!

    I tried it (at the Table level), but there's no improvement.

    Also, I'm now having the opposite problem at the top of this cell. The table (which I can't show b/c of proprietary reasons) has 3 columns. In the 3rd column the first line of text has no whitespace above it in EDIT mode. But in PREVIEW mode there's an unwanted line of whitespace, at least in some cases. Since the other columns have no such whitespace it looks odd.

    I don't understand why PREVIEW mode should render differently from EDIT mode. This behavior certainly complicates things.

     

     

    0
  • Ifra Saqlain
    Community Moderator
    Most Engaged Community Member of The Year - 2021

    Okay, so if you can share the demo screenshots that exactly what do you need?

    You can create a demo table from starting and just add 20px padding in cell-padding and see on the preview mode. 

    Edit mode can't show the effect of padding as my understanding.

    0
  • Stephen Kairys

    Hello, Ifra

    Thanks for checking in. This table actually has 3 columns and my main concern was the inconsistent whitespace at top[ of each column. Column 3 had the problem.

    But my manager and I played around with it a bit. Not exactly sure what we did, but may have added whitespace at the top of columns 1 and 2 so they also had whitespace at the top in preview mode.

    That said, he is satisfied with how this table looks and does not want me to spend any more time making it pretty. Apologies to bail  out of this issue, but it's livable for now and I have higher priority articles on my agenda.

    Thanks again.

    Best,

    Stephen

     

     

    0
  • Ifra Saqlain
    Community Moderator
    Most Engaged Community Member of The Year - 2021

    Okay :)

    0
  • Stephen Kairys

    OK, I'm now concentrating on a different document for a different person, dealing with left-padding issues in a table. The table looks fine in EDIT mode, but in PREVIEW mode, the characters within are too close to the left-hand border, making them hard to read. So, I entered 50px for CELL PADDING but there's no change in both modes. Is this behavior a bug?

     

    Here's the result in EDIT MODE

    Here's the result in PUBLISHED MODE

    FWIW, the display unsafe content option is enabled.

    Also, is there a Zendesk reference guide that explains the above form, including the meaning of each field?

    Thanks,

    Steve

     

    0
  • Mark Glinski

    Looks like Stephen's issue wasn't resolved. I'm having the exact same problem. I have tried every suggestion posted in this page and comment thread: https://support.zendesk.com/hc/en-us/articles/115015961027?

    Please advise, Zendesk!

    1
  • Ryan Walsh

    @..., Same here

    @... please send help, this feature does not seem to function as expected

    0
  • Mark Glinski

    Hi, Ryan

    I had this resolved in a separate article: https://support.zendesk.com/hc/en-us/articles/115015961027?page=3#comment_4405185400346

    Check out @...'s comment at the bottom. She provided a fresh set of CSS for tables, along with an explanatory comment. Hope this helps!

    1

Please sign in to leave a comment.

Powered by Zendesk