"Requester can see this comment" default setting

66 Comments

  • Dave Dyson
    Zendesk Community Manager
    Ah, gotcha, thanks for clarifying, CJ -- I was so focused on solving the mystery of that phrasing change that I didn't answer the core question. 
     
    I've been able to confirm on my two test accounts (one with Agent Workspace enabled, the other without), that deselecting the "Agent comments on all tickets are public by default" checkbox (when Agent Workspace is enabled) or "Agent comments via web are public by default" (when Agent Workspace is disabled), that the "Requester can see this comment" checkbox when merging tickets is deselected by default as well.
     
    I made sure to scroll to the bottom of the Tickets > Settings page in Admin Center and clicked Save, and then when I returned to Support, I refreshed that tab as well. In both accounts, I'd go to Admin Center, changed the setting there and Save, return to Support and refresh that tab, and when I went to merge tickets the checkbox there would obey whatever I'd set in Admin Center. It sounds like you're seeing something different, but can you verify that you're following the same procedure I listed above?
    0
  • Dave Dyson
    Zendesk Community Manager
    Hi Nick, welcome to the community!
     
    Can you verify with your admins that Agent Workspace is enabled on your account? From this end, it doesn't appear to be enabled. See Activating and deactivating the Zendesk Agent Workspace
    0
  • Sorin Alupoaie

    In case it helps, I've built this app recently that automatically merges new tickets that are found as duplicates (same requester & additional configured criteria). Like a "virtual" agent that sits on top of the queue constantly looking for duplicates. By default it adds a private comment to the merged ticket, but you can configure it to add a public comment instead.

    Last but not least, it's affordable (€40 per month with unlimited agents & tickets) and easy to use.

    -1
  • Dane
    Zendesk Engineering
    Hi Annie,
     
    That option is not available for accounts that does not have Agent Workspace. You'll need to enable it to have that option.
     
    -1
  • Cheeny Aban
    Zendesk Customer Care
    Hi Crystal! 

    I can see that you already lodged a support request regarding this inquiry. Rest assured that we'll do our best to help you identify why the setting is not showing on your end. Thanks! 
    -1
  • Dave Dyson
    Zendesk Community Manager

    Hi Anita Nayob and CJ Johnson

    We recently updated the strings for this setting, from "non-email conversations are public by default", to (as CJ's screenshot shows), to “Agent comments on all tickets are public by default". We made this change because the old name was misleading – we respect this setting for email channels too (not just non-email).

    I'll add a note to Giles' comment to help prevent future confusion.

    -1

Please sign in to leave a comment.

Powered by Zendesk