Error with zcli validate and package

6 Comentarios

  • Tipene Hughes
    Zendesk Developer Advocacy
    Hey David,
     
    Can you share the version of ZCLI you’re using, as well as the openssl version and your operating system. Also, is it only the validate and package commands that are generating this error on your end?
     
    Thanks!
     
    Tipene
    0
  • David Noland

    SSL: LibreSSL 2.8.3
    ZCLI: @zendesk/zcli/1.0.0-beta.28 darwin-arm64 node-v19.3.0

    However, I went through and reinstalled the Zendesk Apps Framework and now it no longer uses ZCLI, but uses the legacy ZAT commands, which works successfully.

    0
  • Tipene Hughes
    Zendesk Developer Advocacy
    Thanks for the update, David. If you like, you can try re-installing ZCLI to see if that has any effect; this will bring it up to the latest version which is 1.0.0-beta.31. 
     
    ZCLI and ZAT can be used concurrently so you’ll still be able to validate and package your apps using ZAT if you continue to see issues.
    0
  • David Noland

    I tried reinstalling ZCLI and updated (@zendesk/zcli/1.0.0-beta.32 darwin-arm64 node-v19.3.0) and I get the same error. 


    0
  • Tipene Hughes
    Zendesk Developer Advocacy
    Huh, that’s strange. We haven’t been able to repro on our end. So I can troubleshoot this in more depth, can you provide a few extra details, specifically: what version of macOS are you running and, what web browser is configured as your default and is it up to date?
     
    Also, does this error appear when you run the zcli apps:create or zcli apps:server commands?
    0
  • Nixon Michaelangelo

    Try re-authenticating zcli with the correct subdomain. In our case, our subdomain had changed during partner account migration.

    1. zcli logout

    2. zcli login -i  and provide the right subdomain

    0

Iniciar sesión para dejar un comentario.

Tecnología de Zendesk