문제 증상
티켓을 업데이트할 때 다음과 같은 오류 메시지가 표시됩니다.
티켓 #____을(를) 저장하지 못했습니다. 업데이트를 저장하는 중 이 티켓이 변경되었습니다. 다시 시도하세요.
원인
충돌 오류입니다. 충돌 오류는 두 개 이상의 업데이트에서 동시에 티켓을 변경하려고 할 때 발생합니다. 업데이트 충돌은 업무에 방해가 될 수 있으며 심각한 워크플로우 문제를 야기할 수 있습니다.
상담사에게 이 오류 메시지가 표시되면 상담사가 업데이트하기 바로 전에 다른 이유로 티켓이 업데이트된 것입니다. 두 업데이트가 충돌하려고 하여 Zendesk에서 중지했습니다. 상담사는 업데이트 내용을 다시 제출해야 합니다.
상담사 업데이트와 동시에 발생하는 경우에는 모든 업데이트로 인해 이 오류가 발생할 수 있습니다. 일반적인 원인은 다음과 같습니다.
- 다른 상담사가 동일한 티켓을 등록하고 직접 업데이트 내용을 제출합니다.
- 외부 서비스에서 API 호출로 티켓을 업데이트하는 동시에 상담사가 티켓 업데이트를 제출합니다.
- 설치된 앱에서 업데이트를 제출합니다.
- 상담사가 티켓을 업데이트할 때 티켓에서 자동화가 실행됩니다.
- Talk 통화가 끝날 때 통화 녹음이 추가됩니다.
- Chat 또는 메시징 대화가 끝날 때 채팅 대화 내용이 추가됩니다.
- 사이드 대화가 만들어지거나 업데이트됩니다.
참고: 자체 업데이트의 트리거와 충돌할 수 없습니다. 하지만 동시에 다른 업데이트도 트리거를 실행할 수 있습니다. 즉, 트리거가 충돌 오류와 관련이 있을 수는 있지만 충돌을 일으킬 수는 없습니다.
해결 단계
활성 계정에서 이 오류가 가끔 표시되는 것은 정상입니다. 모든 소스에서 언제든지 업데이트 충돌이 발생합니다.
하지만 이 오류가 자주 발생한다면 워크플로우에 문제가 있을 수 있습니다. 첫 번째 단계는 업데이트 충돌이 어디에서 발생하는지 파악하는 것입니다.
- 오류가 발생하면 티켓으로 돌아가서 티켓 이벤트를 확인합니다.
- 비슷한 시간에 발생한 다른 업데이트를 찾습니다.
- 더 많은 예를 수집하고 패턴을 찾습니다.
패턴을 찾은 후에는 업데이트 충돌을 최소화하도록 워크플로우를 조정합니다. 워크플로우마다 다릅니다.
- 티켓 이벤트 로그를 확인하여 상담사와 동시에 티켓을 업데이트한 내용을 확인합니다.
- 앱 또는 API 스크립트에서 불필요한 업데이트를 많이 만드는 경우에는 설정을 변경하거나 사용 중지하는 것을 고려합니다.
- 상담사가 종종 같은 티켓을 동시에 업데이트하는 경우에는 상담사 충돌 문제가 발생할 수 있습니다. 자세한 내용은 Play 모드에서 상담사 충돌 문제 해결 문서를 참조하세요.
- 상담사에게 사이드 대화가 시작되고 티켓이 업데이트될 때까지 잠시 기다리라고 안내합니다.
- 상담사에게 Talk, Chat 또는 메시징 티켓을 업데이트하기 전에 통화 녹음이나 대화 내용이 표시될 때까지 기다리라고 안내합니다.
- 티켓이 만들어진 직후 적용되는 모든 라우팅 규칙과 자동 업데이트를 검토합니다. 이러한 요소는 매우 신속하게 직접 티켓을 만들거나 신규 고객 티켓을 등록하는 상담사에게 영향을 미칠 수 있습니다.
- 10초 정도 기다린 후 업데이트를 다시 제출합니다.