问题特征

更新工单时,显示以下错误消息:

工单 #____ 未保存。在保存您的更新时此工单已进行了更改。请重试。

原因

这是冲突错误。当两个或更多更新尝试同时更改工单时,就会发生冲突错误。更新冲突可能具有干扰性,并导致严重的工作流程问题。 

如果专员看到此错误消息,则表示在专员更新工单之前,工单刚进行了其它更新。这两个更新会发生冲突,因此,Zendesk 阻止了后者,并需要专员重新提交更新。

与专员更新同时发生的任何更新也可能导致此错误产生。以下是产生此错误的常见原因:

  • 另一个专员打开了同一张工单,并提交了更新。 
  • 在专员提交工单更新时,外部服务通过 API 调用更新了此工单。
  • 已安装的应用提交了更新。
  • 专员更新工单时,工单上的自行程序触发了。
  • Talk 通话结束时添加了通话录音
  • 在线交谈或消息传送对话结束时添加了在线交谈记录副本
  • 创建或更新了协作快捷对话
注意:您不会与自己更新的触发器发生冲突,但同时发生的其它更新也可能触发触发器。换言之,触发器可能与冲突错误有关,但不会导致冲突错误。

解决步骤

在活跃的帐户中偶尔看到此错误是正常现象。任何来源的更新冲突随时可能发生。

但是,如果经常发生此错误,则可能是工作流程出现了问题。要解决此问题,首先要找出更新冲突的来源。

  • 出现错误后,返回工单并检查工单活动日志
  • 查找同时发生的其它更新
  • 收集更多示例并查找模式

找到模式后,调整工作流程以尽量减少更新冲突。工作流程各不相同。

  • 检查工单活动日志,了解到底是什么内容与专员同时更新了工单。
  • 如果应用或 API 脚本创建了大量不必要的更新,请考虑更改设置或将其禁用
  • 如果专员经常同时更新相同的工单,则可能存在专员冲突问题。有关更多信息,请参阅文章:Play 模式中专员冲突的故障排除。
  • 建议专员开始协作快捷对话后稍等片刻,然后再更新工单。
  • 建议专员等待通话录音或对话记录副本出现,然后再更新 Talk、Chat 或消息传送工单。
  • 创建工单后立即检查应用的所有转接规则和自动更新。这可能会影响专员快速创建其自己的工单或开启新的客户工单。
  • 等待 10 秒后重新提交更新。
由 Zendesk 提供技术支持