SUMMARY
On August 04, 2021 from 08:23 UTC to 21:01 UTC, customers using Zendesk Explore were being shown data from dates outside the ranges that were being queried.
Timeline
21:27 UTC | 14:27 PT
We are investigating reports of incorrect date timestamps in Explore reporting and the Agent Workspace UI. We will provide more information as it is available.
21:57 UTC | 14:57 PT
We have identified a potential cause of the Explore date issue, and are working on a fix. We will continue to update as we receive new information.
22:36 UTC | 15:36 PT
We're happy to report that the issue impacting Explore timestamps has been resolved. Our engineering team has determined the Agent Workspace UI timestamp issue is unrelated and will address this in the course of routine platform update
POST-MORTEM
Root Cause Analysis
This incident was caused by a recent code deploy that resulted in a regression of Zendesk Explore’s queries, leading to incorrect data being returned.
Resolution
To fix this issue, we performed a rollback of the deployed code. Recovery was observed thereafter.
Remediation Items
- Improve Zendesk Explore team on call paging processes so that the correct people can be paged more efficiently [Scheduled]
- Redeploy the code in question behind a feature flag [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.