SUMMARY
On November 24, 2020 from 13:22 UTC to 15:40 UTC, Support customers may have experienced browser issues when navigating to a Closed ticket that was assigned to a deleted Group.
Timeline
16:08 UTC | 08:08 PT
We’re happy to report the browser issues in Support have now been resolved. Thank you for your patience.
15:26 UTC | 07:26 PT
We are aware of browser issues opening closed tickets belonging to a deleted group in Support. Investigation is underway.
Root Cause Analysis
This incident was caused by a change to Ticket Status logic to create an undefined state to hold a place for Ticket Status until closure could be determined. This allowed for a new scenario in which, when a ticket was Closed and assigned to a Group that no longer existed, the code created an infinite loop.
Resolution
To fix this issue, we reverted the change.
Remediation Items
Engineering teams have Implemented new tests to check for all potential states of a closed ticket with regards to Groups and Users who may or may not currently exist in an account.
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.