Question

What is causing phone verification calls from Google to fail?

Answer

Google requires a direct mobile or landline number that can receive texts or automated calls without any key press or interference. For verification purposes, using a direct mobile or landline number is recommended.

Cause

You may not be able to receive a phone verification call from Google in Zendesk due to these reasons:

  • Voice over internet protocol (VOIP): Zendesk Talk uses VoIP numbers. These numbers can be rejected by services like Google for verification.
  • Automated call systems: Google verification calls are automated and may not navigate through interactive voice response (IVR) systems or call routing features in Zendesk Talk.
  • Service provider policies: To prevent misuse, Google and other service providers can block verification to business phone systems or shared phone numbers, which might include Zendesk Talk numbers.
  • Zendesk automatically rejects any calls from Google's 2FA number, +12024558888, as 2FA is not supported on Talk lines.

Solution

As a solution, at a quiet time for your business, temporarily try the options below: 

  • Turn off any interactive voice response (IVR) routing
  • Turn off greetings and turn on voicemail so Google's call creates a voicemail ticket, for example:

    1. From Admin Center, go to Channels > Talk > Lines.
    2. Select the line you want to verify.
    3. Switch to the Voicemail tab.
    4. Check that Voicemail is turned on.
    5. Set Greeting (voicemail on) to None.
    6. Ensure that no agents are online.
    7. Launch the Google phone verification process. 
Powered by Zendesk