SUMMARY
During this incident, Sunshine Conversations were unable to be switched to Email conversations for some Sunshine customers.
11:51 UTC | 03:51 PT
We are investigating issues with Messaging interactions being unable to be switched to Email conversations for some of our Sunshine Conversations customers. More information to follow.
12:35 UTC | 04:35 PT
We are happy to report that the issue that hindered some of our Sunshine Conversations from changing to the email channel on Messaging tickets has now been resolved! We apologise for the inconvenience.
POST-MORTEM
Root Cause Analysis
A Sunshine Conversation environment variable configuration change resulted in code being unable to find a variable resulting in 401 errors. I
Resolution
In order to resolve the incident, the config variable was added back manually and a deployment was triggered.
Remediation Items
- Update configuration with variable
- Update automatic deploy to happen during business hours
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. During an incident, you can also receive status updates by following @ZendeskOps on Twitter. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us.