Could not find com.google.android:flexbox:2.0.1 required by project :app > com.zendesk:messaging:5.2.1

6 댓글

  • Eric Nelson
    Zendesk Developer Advocacy
    Hey Hanae,

    Unfortunately, Zendesk doesn't support React Native for our SDKs. Though I'm going to leave this post open to see if someone from the community can assist! 
    0
  • Ivan Grechishchev

    Hi Hanae, 

    try adding FlexBox 2.0.1 explicitly in your build.gradle 

    implementation 'com.google.android:flexbox:2.0.1'
    -1
  • Akash Koradia

    Hi Eric,
    I am facing same issue in Kotlin. Does Zendesk not support Kotlin also? I already have flexbox dependency in my code but still getting above issue.

    0
  • Mick O'Donnell
    Zendesk Product Manager

    Hi Akash,

    We do support Kotlin for our SDKs. We'll current working on a new release of our Android SDKs to resolve this issue. In the meantime, you should be able to work-around this issue by upgrading to Flexbox 3.0.0.

    We'll update the release notes as soon as the release is available.

    1
  • Akash Koradia

    Hi Mick, thank you for responding.
    I was able to resolve the issue - using exclude flexbox line in the dependency. As you can see below

    implementation 'com.google.android.flexbox:flexbox:3.0.0'
    implementation (group: 'com.zendesk', name: 'messaging', version: '5.2.2') {
    exclude group: "com.google.android", module: "flexbox"
    }
    implementation (group: 'com.zendesk', name: 'chat', version: '3.3.2') {
    exclude group: "com.google.android", module: "flexbox"
    }

    this worked for me 

    1
  • Mick O'Donnell
    Zendesk Product Manager

    Awesome Akash, glad to see it's solved! FYI, we're updating the SDK to use Flexbox 3.0.0 out of the box. This updating will be available shortly.

    0

댓글을 남기려면 로그인하세요.

Zendesk 제공