Summary
On April 27, 2026 from 12:55 UTC to 15:25 UTC, we received reports of Zendesk Support customers on Pod 27 experiencing significant latency in Views. This included delays in real-time updates and, in some cases, display failures or incorrect ticket and view states, impacting agents’ ability to monitor and manage tickets effectively.
Timeline
April 27, 2026 15:02 UTC | April 27, 2026 8:02 AM PT
April 27, 2026 15:17 UTC | April 27, 2026 8:17 AM PT
We have confirmed an issue causing search delays for customers in Pod 27, also affecting Ticket Views updating with newly submitted ticket updates. Our team is investigating, and we will provide further updates when we have new information to share.
April 27, 2026 15:36 UTC | April 27, 2026 8:36 AM PT
We are seeing improvement in the issue causing Search delays for customers in Pod 27, and latency has dropped significantly. Please let us know if you are still experiencing any issues.
Looking forward to your response.
April 27, 2026 16:10 UTC | April 27, 2026 9:10 AM PT
We are happy to report that the issue affecting Views in Pod 27 has been resolved, and Views are sorting as expected at this time. Thank you for your patience during our investigation.
Root Cause Analysis
This incident was caused by an unusually large background re-indexing job running across multiple environments at the same time, which overloaded the underlying indexing infrastructure and reduced its ability to process and serve view updates promptly.
Resolution
To fix this issue, the team completed the data restoration and allowed the system to rebalance resources, which reduced delays and errors, restoring near real-time updates on Pod 27. This recovery was confirmed through testing and customer feedback.
Remediation Items
- Establish clear guidelines for the Views team on when to escalate incidents.
- Update internal documents to include steps for increasing system capacity when backfill processes are required.
- Review and improve the overall system design related to backfill operations for Views to prevent future issues.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. If you have additional questions about this incident, contact Zendesk customer support.