Previewing theme changes locally

Return to top

10 Comments

  • Pasquale Errico

    I have a problem, i think, with livereload and ZAT.

    If a launch Zat Theme Preview my pages are unformatted and slowly, the console show this:

    and some others.

    I have allowed the Insecure Content on Chrome and also test with zat theme preview --no-livereload but doesn't work.

    I must work with online data, on our guide, but it seems impossibile!

    There is a work around for this problem?

    Thanks a lot

    0
  • Greg Katechis
    Zendesk Developer Support Team

    Hi Pasquale! For an issue like this, I would recommend reaching out directly to our Advocacy team so that they can get additional information needed to assist here.

    0
  • Ben

    Just wanted to reach out here to see if anyone has been running into issues with the ZAT when trying to work on themes locally. For some reason it's not picking up changes to template files any more and I have to close down and rerun zat theme preview for every change. 

    One of my team also is getting intermittent issues where it's taking ages to fully spin up with web server which is doubly annoying given the above. 

    1
  • Paweł Porombka

    Hi, I had same problems over 1 year ago. The API for local development is just bad. I created custom solution for it because I spent 2 weeks trying to make it fully work. No chance. Server breaking connection, continuous problems with uploads etc. I created own continuous deployment scripting in Gulp. It is working and I advice to do the same. Zendesk API allowed to do it all by myself.

    0
  • Keith Bottner

    Trying to set this up and the first step is a show stopper, it says:

    1. If not already done, enable API access in your Zendesk Support account by going to Admin > Channels > API.

    However, when I go to Admin > Channels there is no API and there is no way to add API. Did something change in how to configure this?

    0
  • Cheeny Aban
    Zendesk Customer Care

    Hi Keith,

    You can access API by going to Admin(the one that looks like the wheel icon on the left side of the screen)>Channels>API. If you are still unable to see it, you may reach out to our Customer Support so they can have a closer look into your account

     

     

    0
  • Joshua Small

    I have host mapping enabled, and when I navigate to the URL generated by theme preview, I'm redirected to the specified host mapping. When I set the domain to the specified host mapping, navigating to the generated URL still redirects. What is the recommended means of previewing themes when using host mapping?

    0
  • Cheeny Aban
    Zendesk Customer Care

    Hi Joshua,

    When previewing your Help Center, you can also go to your Guide Admin>Themes>Them that you would like to preview> On the preview page, you can choose the Template and the preview role can be changed from end-user to admin

     

    0
  • Trey Harvell

    **Never-mind, it's now inexplicably working.**

    Weird. I posted this message on Friday and it's missing now.

    I'm working on setting up my local Zendesk Guide theme so I can make some changes.  I've followed the instructions here, but when I do step 4 "Copy the "Ready" URL in the output and paste it in a browser."  the help center just redirects to my main Guide page.  Am I missing something?

     

    1
  • Gabriele F.
    Hi Trey! As I can see from your last add into the comment this is now self solved and these lead to a temporarily glitch. I'll set this one to Solved status as well, if you're facing some other issue feel free to reach back and we will continue the troubleshooting.
    0

Please sign in to leave a comment.

Powered by Zendesk