Help center CSS cookbook

Return to top

40 Comments

  • Christopher Stock
    Community Moderator
    Zendesk Luminary

    Hey Timo Boezeman, it's added as a <zd-autocomplete> element. There are no css classes, but you can style the element directly.

    0
  • Timo Boezeman

    Thanks Christopher Stock!

    0
  • Gorka Cardona-Lauridsen
    Zendesk Product Manager

    Hi All, 

    We are conducting research to improve our Help Center developer experience and would love to talk to any of you that have tried to edit Help Center theme code.

    If you are interested please answer sign up here and answer the 3 survey questions. I will reach out to you to setup a 30 min Zoom call.

    The interview will be a semi-structured interview where we would like to hear you take us through examples of what you have done or tried to do with customizations and your experience with the tools, documentation etc. you used.

    Looking forward to talking to all of you.

    Gorka Cardona-Lauridsen
    Sr. Product Manager, Zendesk Guide 

    0
  • Casey Keefe

    Hi Everyone - Anyone have any ideas why the closing tag for <script> here is showing in red? I've gone line-by-line, but can't seem to figure it out. Thanks in advance!

    0
  • Greg Katechis
    Zendesk Developer Advocacy

    Hi Casey! It's difficult to say for sure, but one possibility is that you're adding this to your script.js file, that could be one possibility. You don't need to wrap any js code in script tags on that file, so this is one possible error that would show up. If that isn't what you're doing, could you let me know which file you're adding this to?

    0
  • Casey Keefe

    Thank you Greg-Katechis ! This code is currently on new_request_page.hbs

    0
  • Greg Katechis
    Zendesk Developer Advocacy

    Thanks for sharing! I just tried a for loop on my new request page and I was getting a similar linting "error", but when I loaded the page, it was executing properly. I can bring this to our dev team to see what's going on here, but first I'd like to know if you're seeing the same behavior as I am. Just let me know if the code is working and if it is, at least we know that's not the issue and we can narrow the scope of the fix.

    0
  • Casey Keefe

    Hi Greg-Katechis - Thanks! Yes, we have been getting the same result. This code has been on the live page for months with no reported issues as well.

    For a bit more scope - we are essentially trying to add some login functionality to one of the forms and when updating the code, I came across this script error, so figured I would try and fix it while adding the new functionality.

    0
  • Max

    Hello there, 

    I am trying to modify the appearance of Send a request link button, but nothing changes.. I am with Copenhagen v3.1.0. Is it because the colour chosen on the homepage og theming is overriding my code ? 

    Here is my code if it can help

    /***** Change style of the request button *****/
    .submit-a-request {
      font-size: 14px;
    color: #B78A6B;
      background: #ffffff;
    }

    Thank you loads !

    0
  • Andrey Nikolaev

    Can I change an article's CSS template for just one section or category rather than the entire Help Center?

    0

Please sign in to leave a comment.

Powered by Zendesk