Ticket not saved: A change was made to this ticket as your update was being saved

Return to top

23 Comments

  • Shelbee Butler

    So, this has been happening to my team. However, the list given of reasons why this happens does not apply to us. Agent collision is not an issue since there are 3 people who update tickets, and none of them are ever on the same ticket at the same time. We do not use Play Mode. We do not use any APIs. We do not have any installed apps. We do not use calls through Zendesk. We do not use chat through Zendesk.

    The only thing we do use is triggers and automations, but only the default ones upon setup: "Trigger Notify requester and CCs of comment update" is the only trigger we have. And the only automation we have is the default survey that sends out once the ticket is moved to a "Closed" status, so that should not be interrupting our tickets being saved.

    Our agents are constantly getting this error when saving tickets, so we need to know how to rectify this error since it seems to be an issue not related to these causes.

    2
  • Dainne Lucena
    Zendesk Customer Care

    Hi Shelbee Butler

    As this needs troubleshooting, I went ahead & created a ticket for your concern from your community comment so that our Advocacy team can further troubleshoot what is happening on your agent's end. Please keep an eye out for an update from our team & also have a HAR file ready that documents what is happening on your agent's end. A HAR file can help identify what is going on from the browser & network's end as to why your team is getting that error. 

    0
  • Shelbee Butler

    Thank you Dainne, I appreciate you getting back to me about this. I will create that file and await your team's response.

    0
  • Ariadna Mateo Rodríguez

    Hi there!

    My team is also experiencing the same problem. We realized that it happens when trying to submit a ticket with an attachment and when merging tickets. 

    0
  • Gabriel
    Zendesk Customer Care
    Hi there!

    I hope all is well! Please, kindly see addressed in the article that the causes of this can happen during any ticket update, therefore, displaying the message. Please see that for your case you should still apply the proposed resolution steps. 

    I hope this helps! 
    0
  • Angela Moran

    We are experiencing this issue too, more frequently over the last week. The troubleshooting suggestions don't seem to apply to us - we are very similar to the issue experienced by Shelbee Butler - 

     Agent collision is not an issue since there are 4 people who update tickets - none of them are ever on the same ticket at the same time. We do not use Play Mode. We do not use any APIs. We do not have any installed apps. We do not use calls through Zendesk. We do not use chat through Zendesk.

    Our 4 agents are getting this error when saving tickets (saving as Open and Closed) but not when merging tickets. I have tried to see the Events history for what trigger or automation is occurring at the point of saving and cannot see anything obvious.

    Has something change to cause this issue for multiple users all of a sudden?

    Thanks,

    0
  • Luke Desmond

    We are experiencing this issue too now. It's become a global issue anytime we attempt to close a ticket that has an "inline link attachment" in the body of the message. We have reviewed the "events" logs and doesn't seem to be any conflicting triggers or automations happening in the background. Please help. 

     

    1
  • Luke Desmond

    Additionally after the "Ticket Not Saved" message pops up ... and you go back to the ticket ... and resubmit it goes through. 

    1
  • Angela Moran

    Yes, same for us too. We only have the error message/conflict once and then any subsequent requests to save/try again is successful.

    0
  • Brett Bowser
    Zendesk Community Manager
    Hey everyone,
     
    Thanks so much for bringing this to our attention! We will most likely need to assume into your account to see what's going on here. I'd recommend reaching out to our Customer Care team in your account so we can troubleshoot this with you further.
     
    More information on reaching our customer care team here: Contacting Zendesk Customer Support
     
    Cheers!
     
    0
  • Angela Moran

    I've done that and not had a response - happy for someone from the Zendesk Customer Support team to reach out to me proactively.

    Also, this problem seems to occur from the same time most days. Around 12.30pm NZT is when we experience this issue more frequently. This is also the time when fewer agents are on as they are taking lunch breaks so less like to be agents working the same ticket. 

    0
  • Brett Bowser
    Zendesk Community Manager
    Hey Angela,

    I'm going to create a ticket on your behalf so our Customer Care team can look into this for you.
     
    You'll receive an email shortly stating your ticket has been created.
     
    Cheers!
    0
  • Darren Bell

    We have also been getting this over the last couple of weeks, at least.

    I have replicated it. If you have a ticket at Pending, and the end-user replies with an attachment such as a screenshot pasted into the message, then the Agent replies with a public message.  

    Checking the events and we have 

    • Total time spent (sec) 
    • Time spent last update (sec) 
    • Trigger: Notify requester of comment update

    I have logged a ticket with Zendesk.

    0
  • John Carling

    We are experiencing this same issue.

    0
  • Eric Z

    Like everyone else we've had multiple reports of this issue over the last week with from our agents as well (although they're able to resubmit successfully following the error).

    0
  • Brett Bowser
    Zendesk Community Manager
    Hey Eric,

    Can you try reaching out to our Customer Care team using the following instructions: Contacting Zendesk Customer Support
     
    They will need to take a look a couple ticket examples to figure out why this is happening. 
     
    0
  • Perl Bognot

    Hi,

    Like everyone else, we've had multiple reports of this issue over the last week withour agents as well (although they're able to resubmit successfully following the error).

    We haven't received the help we need because upon trying Contacting Zendesk Customer Support, a chat bot is what responds and couldnt take care of our issue. 

    Hopefully someone reaches out to help us sort this out. Thanks!


    2
  • Darren Bell

    I logged this with Zendesk on 20th June, I supplied a replicable case in our Zendesk instance, video recording and a .HAR file. I had to escalate the case (via Twitter) as nothing was happening with it and the last update from them on the 13th July is that it had been passed to the Dev team.

    0
  • Dave Dyson
    Zendesk Community Manager
    Darren, thanks for your patience as our team works to figure this out -- i realize it can be frustrating when you don't hear back. I've passed along your comment and I'm following your ticket so I can keep an eye on it.
     
    Perl, I'm going to create a ticket on your behalf so our team can investigate your issue as well.
    0
  • Perl Bognot

    Hi Dave,

    I was trying to reply to the ticket you raised for my concern that was related to this but I keep on getting an error that says "Whoops, this email address is no longer monitored as we have moved our support experience to messaging in order to provide you with faster, more personalized support."

    Please help me move forward about this issue so I can send the information you need. The issue still persists as of this writing. Thank you!

    0
  • Dave Dyson
    Zendesk Community Manager
    Perl, sorry about that! I think that may have happened because your ticket had been solved and closed, but I'll check on that. In the meantime, please contact our support team directly and they should be able to help: Contacting Zendesk Customer Support
    0
  • Francis Morissette

    This has also been happening to me in my instance, and I'm the only agent. It's been a few months since this started, sometimes I will submit the change, not notice it, only to see an hour later that my SLA has gone over since I hadn't replied. 

    None of the causes here apply to me.

    0
  • Brett Bowser
    Zendesk Community Manager
    Hey Francis, 
     
    Can you try reaching out to our Customer Care team using the steps Dave shared above so they can dig into this with you? We will most likely need some ticket examples to see why this issue is occurring. 
     
    Thanks!
    0

Please sign in to leave a comment.

Powered by Zendesk