Summary
On October 22, 2022 from 01:10 UTC to 09:39 UTC, customers on multiple Pods experienced partial degradation of service when sending messages to WhatsApp.
Timeline
05:31 UTC | 22:31 PT
We are investigating reports of Whatsapp issues causing messages to not be delivered or received for some customers. We will provide an update in 30 minutes or when we have new information.
06:06 UTC | 23:06 PT
The WhatsApp Graph API is currently experiencing a service disruption which is causing WhatsApp messages to not be sent or received. We will provide an update in the next hour or as soon as we have more information to share.
07:00 UTC | 00:00 PT
We're continuing to monitor the status of the WhatsApp Graph API service disruption which is causing WhatsApp messages to not be sent or received and awaiting resolution from Meta. We will provide an update as soon as we have more information to share.
09:15 UTC | 02:15 PT
We have identified the likely cause of the WhatsApp Graph API service disruption which is causing WhatsApp messages to not be sent or received and we’re awaiting resolution from Meta. We will provide another update once we have more information, thank you for your cooperation.
11:46 UTC | 04:46 PT
We’re continuing to work on the issue which is causing WhatsApp messages to not be sent or received. We’re awaiting resolution from Meta, also if the issue is solved for some customers. We will provide an update once we have more information, thank you for your cooperation.
15:44 UTC | 08:44 PT
We're happy to report that the WhatsApp Graph API service disruption which caused WhatsApp messages to not be sent or received is now fully resolved. Please let us know if you continue to experience issues.
Root Cause Analysis
This incident was caused by permission errors in WhatsApp’s Graph API layer. The resolution time was extended during this incident due to the complexity of the issue that involved multiple internal teams as well as our service provider.
Resolution
To fix this issue, our service provider resolved the underlying permissions issue in the API.
Remediations
Zendesk has reviewed that our WhatsApp-related monitors worked correctly and that alerts fired promptly to our engineering teams.
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.