[BREAKING] Announcing the deprecation and replacement of Status API endpoints

Return to top

5 Comments

  • Simon Blum

    hi, 

    I'm getting a no content in response to GET https://status.zendesk.com/api/incidents/active - is this abnormal?

     

    Thanks

     

    0
  • Greg Katechis
    Zendesk Developer Advocacy

    Hi Simon! In the event that there isn't currently an active incident, you should receive a 200, but with an object that contains two empty arrays; `data[]` and `included[]`. So if you mean this in the sense of a 204 status, then that isn't what I would expect to see. If it's a more literal "no useful content" there, then that would be expected. I'm getting the feeling that it's an actual 204, so if that's the case, let me know and we can dig into this further.

    0
  • Simon Blum

    Greg-Katechis that's ok then, the expected behaviour wasn't clear to me in the docs

     

    0
  • Simon Blum

    Additionally, is the response from the API the live status or should we expect some delay in the response?

    Thanks

    0
  • Greg Katechis
    Zendesk Developer Advocacy

    No delay, that is going to be the live status. Aside from browser caching, latency inherent in the internet, etc., it will be the current view of things at Zendesk, as we report it. It's possible that you might experience an issue before we have it flagged, but that's less of a delay and probably not what you meant!

    0

Please sign in to leave a comment.

Powered by Zendesk