Summary
From February 6, 2024 at 22:45 UTC until February 7, 2024 at 06:15 UTC, Zendesk Sell customers using the Zapier integration experienced authentication issues when using the integration.
Timeline
10:04 UTC | 02:04 PT
We have received reports of customers experiencing errors with Zapier being unable to authenticate to Zendesk Sell. We are investigating this as a matter of priority, and will provide another update when we have more details to share.
04:29 UTC | 20:29 PT
We have had confirmations of recovery from customers who have performed the re-authentication process from Zapier to Sell. If you are still encountering issues, we recommend proceeding with the re-authentication. We will continue to monitor closely, and will provide another update upon confirmation of resolution.
06:28 UTC | 22:28 PT
After further monitoring and more positive confirmations, we are happy to report that this issue has been resolved. Thank you for your patience and partnership as we got to this point.
Root Cause Analysis
This incident was caused by an internal process issue that removed the authentication credentials of the Zapier Sell integration.
Resolution
To fix this issue, our team restored the missing credentials from a recent database snapshot.
Remediation Items
- Create new access-related operations procedure [Scheduled]
- Review and improve Sell application authentication guardrails [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.