Summary
From February 22, 2024 at 23:07 UTC until February 29, 2024 at 21:23 UTC, Zendesk Support customers using the beta Organization Merge feature may have experienced unexpected changes in some closed Support tickets. The feature was re-enabled for beta participants on March 19, 2024.
Timeline
Feb 29 - 21:45 UTC | 13:45 PT
Due to a recently introduced software defect that has caused some closed tickets to be unintentionally be updated, we have temporarily disabled the merge organization (beta) feature. We will provide an update once we're able to identify the root cause and fix the underlying issue, until then the merge organization feature will remain disabled indefinitely.
Mar 19 - 00:53 UTC | 17:53 PT
We are happy to report that the issue with closed ticket updates is now resolved. In addition, we have re-enabled the merge organization (beta) feature earlier today. We sincerely apologize for the inconvenience of this issue and for the extended resolution time. Thank you.
Root Cause Analysis
This incident was caused by a bug in the Organization Merge feature causing incorrect handling of closed ticket updates.
Resolution
To fix this issue, our team disabled the feature to prevent additional erroneous updates to closed tickets and fixed the underlying bug that caused the original issue.
Remediation Items
- Implement additional system tests to verify closed ticket update use cases [Scheduled]
- Implement smoke tests to verify closed ticket update workflows are working as expected [Scheduled]
- Investigate killswitch for modifying closed tickets flow [Scheduled]
- Refine closed ticket update mechanism to only allow specific use cases [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.