SUMMARY
On March 14, 2024 from 18:35 UTC to 19:53 UTC, Zendesk Support customers experienced an issue where some shared views were not displayed in the Views panel. Views were reduced from 30 to 12.
Timeline
19:20 UTC | 12:20 PT
We are investigating reports of Support views not displaying the full 30 shared views, and instead are only displaying 12 shared views. We will provide another update in 15 minutes or when we have more information.
19:34 UTC | 12:34 PT
Our engineers have confirmed the issue impacting the visitbility of shared views. You can still access views in the admin center or views search. Next update in 30 minutes or when we have new information.
19:54 UTC | 12:54 PT
Our engineers have rolled back a change and can confirm the issue affecting shared views is now fully resolved.
POST-MORTEM
Root Cause Analysis
This incident was caused by human error where a feature flag was removed in an internal system. This flag controlled the availability of the increased views count feature. When the flag was removed it returned the available views to a count of 12.
Resolution
To fix this issue, our team restored the feature flag and views returned to the expected number immediately thereafter.
Remediation Items
- Implement additional validation to internal feature management system [Scheduled]
- Investigate and fix feature management recovery mechanism [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, please log a ticket with us via ZBot Messaging within the Widget.