SUMMARY
Between May 13, 2024 20:50 UTC and May 14, 2024 12:02 UTC, some customers using the Firefox browser were unable to load Views in the Support user interface.
Timeline
May 14, 2024 09:18 AM UTC | May 14, 2024 02:18 AM PT
We are currently investigating reports of Support Views not loading properly for customers using the Firefox browser. A possible workaround is to use Chrome instead or update Firefox to the latest version in the meantime. We will provide another update when we have more information.
May 14, 2024 12:12 PM UTC | May 14, 2024 05:12 AM PT
We have deployed a fix for the issue that was preventing Support Views from loading properly for customers using multiple browsers across various Pods. We kindly request that you refresh your browser and/or clear your cache and cookies to ensure you are using the most updated version of the system. Thank you for your patience during this disruption.
May 14, 2024 01:04 PM UTC | May 14, 2024 06:04 AM PT
Having received positive confirmations from customers about the successful implementation of the fix, we are now marking this incident as fully resolved. Thank you again for your patience throughout this process.
POST-MORTEM
Root Cause Analysis
This incident was caused by an escaped bug associated with a specific web design element only affecting older versions of Firefox.
Resolution
To fix this issue, we deployed a software version that reverted the change that caused the issue. At the same time, we advised affected customers to update their Firefox browser to the latest version. Upon further monitoring and with customer confirmation, the issue was resolved.
Remediation Items
- Include older browser versions in our testing processes. [Scheduled]
- Update the supported browser list to more than just the latest two versions. [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, contact Zendesk customer support.