SUMMARY
On May 24, 2024 from 07.00 am UTC and 19:45 UTC customers across all Pods experienced emails integrated with Sell to disconnect.
Timeline
May 24, 2024 06:52 PM UTC | May 24, 2024 11:52 AM PT
We are investigating reports of Sell emails disconnecting, preventing use of the email integration. More information to follow shortly.
May 24, 2024 07:07 PM UTC | May 24, 2024 12:07 PM PT
We have confirmed an issue causing emails integrated with Sell to disconnect, preventing use of the integration. Our team is investigating and we will provide further updates within the next 30 minutes.
May 24, 2024 07:45 PM UTC | May 24, 2024 12:45 PM PT
Our engineers continue to investigate the issue causing emails integrated with Sell to disconnect, preventing use of the integration. We will provide another update in 1 hour or when we have new information to share.
May 24, 2024 07:53 PM UTC | May 24, 2024 12:53 PM PT
We're happy to report that our engineers have rolled back a change and can confirm the Sell email integration issue is now fully resolved. Please let us know if you continue to experience issues.
POST-MORTEM
Root Cause Analysis
Due to a software bug, our system was not attempting to authenticate with the preferred method if at least one prior authentication attempt had failed for a given integration.
Resolution
To fix the issue our team redeployed the system.
Remediation Items
- Investigate possible new alerting for this issue [Scheduled]
FOR MORE INFORMATION
For current system status information about your Zendesk, check out our system status page. The summary of our post-mortem investigation is usually posted here a few days after the incident has ended. If you have additional questions about this incident, contact Zendesk customer support.