SUMMARY
On April 23, 2025 between 18:01 to 19:50 UTC, Support customers on Pod 17 experienced delays in ticket updates reflecting in Views, and inaccurate ticket counts in Views.
Timeline
April 23, 2025 07:43 PM UTC | April 23, 2025 12:43 PM PT
We are investigating reports of delays in ticket status updates being reflected in Views for Pod 17 customers. Our engineers are addressing the issue and customers should be seeing less lag in Views refresh.
April 23, 2025 07:59 PM UTC | April 23, 2025 12:59 PM PT
Views refresh latency in Pod 17 has returned to normal. If you continue to see tickets display in Views that should not, please refresh your browser or clear browser cache.
POST-MORTEM
Root Cause Analysis
This incident was caused when Views traffic was prematurely redirected to new infrastructure which handles Views traffic during a routine update.
Resolution
To fix this issue, our engineering team increased the capacity of the new infrastructure to expedite clearing the backlog and restore Views response times.
Remediation Items
- Increase Views lag visibility particularly during routine infrastructure changes.
- Update paging and alerting to notify teams earlier.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.