Summary

On June 26, 2025, from 16:35 UTC to 17:31 UTC, customers using our Channels integration for Twitter experienced disruptions when attempting to handle incoming direct messages. During this period, the system encountered errors that prevented user profiles from being created, which in turn stopped messages from being converted into support tickets.

Timeline

June 26, 2025 05:36 PM UTC | June 26, 2025 10:36 AM PT

We are aware of an issue with Twitter/X integrations causing new incoming messages to fail silently. Updates to ongoing conversations are not affected at this time. We are working with our partner provider to address the impact but in the meantime, you may need to log into Twitter/X directly to view new messages.

June 26, 2025 05:52 PM UTC | June 26, 2025 10:52 AM PT

We are happy to report that the issue affecting new incoming Twitter/X messages has been resolved and new conversations are being created as expected. Thank you for your patience during our investigation.

Root Cause Analysis

This incident was caused by a temporary problem with Twitter's service that resulted in internal errors. This service is essential for obtaining user information for new Twitter users interacting with our Channels integration.

Resolution

To fix this issue, we closely monitored the situation while we waited for Twitter to restore its service. Once their system started working normally again at 17:31 UTC, our service returned to normal operation.

Remediation Items

Currently, there are no specific remediation items to address, as the issue originated from Twitter/X's systems.

FOR MORE INFORMATION

For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.

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