Summary
On July 05,2025, between 8:00 and 14:00 UTC, we received 5 reports of customers hosted on Google Cloud Platform experiencing issues with agent status values not updating correctly.
Timeline
August 04, 2025 15:45 UTC | August 04, 2025 8:45 AM PT
We have received reports of some customers experiencing assignments getting stuck in Pending status within the Zendesk QA service. Our engineering team has deployed a fix and is actively monitoring the system to ensure stability.
We apologize for any inconvenience this may have caused and appreciate your patience as we continue to address the situation.
August 04, 2025 19:02 UTC | August 04, 2025 12:02 PM PT
Zendesk QA assignments being stuck in Pending status has been resolved for nearly all customers. If you continue to see these issues in your account please submit a ticket so we can investigate further.
August 06, 2025 14:57 UTC | August 06, 2025 07:57 AM PT
We are pleased to inform you that the issue causing some customers’ assignments to get stuck in Pending status within the Zendesk QA service has been resolved.
Thank you for your patience and understanding while our team worked diligently to address this matter.
Root Cause Analysis
This incident was caused by a problem with the agent status page for customers using Google Cloud Platform, which caused incorrect information to appear. This was due to a slow database query pulling too much data.
Resolution
To fix this issue, the team limited the data used and optimized the query. Engineering also corrected any inaccurate information from the incident as part of the fix.
Remediation Items
- Set up alerts to notify the team by email if data stops coming in or if there is a delay in the system.
- Reduce unnecessary alerts from the Kafka system to focus on the most important issues.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.