SUMMARY
On November 13, 2025, between 01:40 UTC (November 12, 2025 05:40 PM PT) and 04:00 UTC (November 12, 2025 08:00 PM PT), customers across all pods experienced difficulties loading and accessing the Zendesk QA dashboard.
Timeline
November 13, 2025 03:00 AM UTC | November 12, 2025 07:00 PM PT
We are aware of the issue affecting access to Zendesk QA, where the page appears blank and continues to load when opened in a new tab. Our engineering team is currently investigating the matter, and we will provide an update within the next 30 minutes. Thank you for your patience.
November 13, 2025 03:28 AM UTC | November 12, 2025 07:28 PM PT
The team is monitoring early signs of improvements in Zendesk QA. Our engineering team is actively investigating the issue to identify and implement a swift resolution. We apologize for the inconvenience this may have caused and appreciate your patience and understanding.
November 13, 2025 04:20 AM UTC | November 12, 2025 08:20 PM PT
Despite some signs of recovery we are aware that intermittent errors are still appearing in Zendesk QA. Our team continues to work at the highest priority to recover QA services. Thanks for your continued patience while we work through this issue.
November 13, 2025 05:08 AM UTC | November 12, 2025 09:08 PM PT
Our teams continue to investigate the intermittent issues affecting Zendesk QA including the Reviews dashboard which remains in a degraded state. While most users can access the service, there are errors persisting for others. We are drafting in additional engineers to ensure we can resolve the remaining issue as quickly as possible. Next update in 60 minutes or sooner if substantive information is available to share. Thank you.
November 13, 2025 06:06 AM UTC | November 12, 2025 10:06 PM PT
Our teams are actively addressing the ongoing intermittent issues affecting Zendesk QA, particularly with the Reviews dashboard, which continues to experience performance challenges. Our engineering team is diligently working to resolve these issues as quickly as possible. We appreciate your continued patience and understanding.
November 13, 2025 07:15 AM UTC | November 12, 2025 11:15 PM PT
Our team is actively collaborating with our external service provider to thoroughly investigate and resolve the intermittent issues with the dashboard in Zendesk QA. We will provide updates as more information becomes available. Thank you for your patience and understanding.
November 13, 2025 08:25 AM UTC | November 13, 2025 12:25 AM PT
We are pleased to inform you that the issue preventing Zendesk QA from loading has been resolved. However, our team continues to investigate intermittent issues affecting the Dashboard in Zendesk QA. As this has been identified as a separate issue, we’ll be publishing a dedicated Help Center guide and providing updates on our status page to ensure continued transparency. Thank you for your patience and understanding while we work to fully resolve this matter.
Root Cause Analysis
The incident was caused by a service consuming all available database connections, leading to a complete Zendesk QA outage. Restarting the MySQL database restored connectivity, and the ongoing Reviews dashboard issues have been isolated as a separate problem.
Resolution
To fix the issue, our engineers scaled down the impacted services and restarted the database to reestablish connectivity. All import data services that had gone offline were subsequently scaled back up and are under continuous monitoring. The dashboard-related issue was isolated and managed independently.
Remediation Items
- Update alert routing to ensure the QA team is promptly notified when MySQL connections approach exhaustion.
- Adjust monitoring thresholds for backend errors to enable earlier detection and alerting of gradual service quality degradation.
- Implement processes to better manage long-running database schema changes to reduce their impact on system performance and availability.
FOR MORE INFORMATION
For current system status information about Zendesk and specific impacts to your account, visit our system status page. You can follow this article to be notified when our post-mortem report is published. If you have additional questions about this incident, contact Zendesk customer support.