Customizing pre-chat form to display a specific department with a custom label

3 Comments

  • Tipene Hughes
    Zendesk Developer Advocacy
    Hi Gizem,
     
    Thanks for reaching out!
     
    With regard to the departmentLabel not functioning correctly, you'll just need to move that property inside the prechatForm object and you should be all set. Apart from that, there isn't anything that immediately stands out from the code you've provided that would cause issues with enabling departments via the webWidget settings object. A couple quick things here to try just to be sure: 
    • Check that the Quick_chat department is enabled for chat in Departments tab of chat settings (this should already be the case since it appears in the default dropdown but just want to be sure).
    • Ensure that there is an agent online for the Quick_chat group when testing your custom code. The department will not be available in the drop down box if no agent is online in the group to receive the chat.  
    If you have no luck with either of those, let me know and we can move this in to a ticket so I can take a look in a bit more detail.
     
    Feel free to reach out with any questions!
     
    Tipene
     
     
    1
  • Gizem Candemir

    Hello, could someone from Zendesk please take a look my question here? 🙏

    Looking forward to hearing back and hopefully fix my issue 🤞

    Best,

    Gizem

    0
  • Luca Baldini

    Hi Tipene,
    I have the same problem.
    The "enable department" command is not working properly ( until last week it was working). This causes us a series of problems because if the department is closed the Chat button will not deactivate. How can I do this? Thanks

    0

Please sign in to leave a comment.

Powered by Zendesk