Enabling Article Recommendations in Web Widget (Classic)

Return to top

24 Comments

  • 上城隆彦

    Hello
    I saw "To enable Answer Bot for the Web Widget" to enable Answer Bot.
    However, I don't see the Answer Bot toggle in my account.
    The Answer Bot item will also not be displayed for another account.
    You should have an add-on, but is there something missing?
    Even if I contact Japanese support, I am in trouble because there is no reply.

    0
  • Elissa Tikalsky
    Zendesk Digital Resources Team

    Hello カミジョウ タカヒコ,

     

    I'm sorry you had trouble with the Answer Bot for Web Widget. I did check your support ticket and I see that you were able to get help in that ticket after posting here. 
    If you have anymore trouble let us know!

    0
  • aku Nna

    Hello @... 

    I am setting up answer bot, I have a question please. 

    The answer bot does not close or refresh after the customer responds to the customer satisfaction survey. Even refreshing the browser doesn't help and the answer bot stops responding.  

    Thanks

    0
  • Cheeny Aban
    Zendesk Customer Care

    Hi Tn,

    I'm sorry to hear that your Answerbot is behaving differently. Have you tried to clear cache and cookies, and use an incognito browser to see if the issue will persist?

    All the best!

     

    0
  • Toni Ikar

    Hi Zendesk Team,

    is it possible to use the answer-bot outside our working hours and deactivate him while we have live support ?

    1
  • Jon Simone

    I prefer this behavior from Answerbot currently (the classic non-flow builder version that is) as it pays attention to business hours, availability and allows for different channels.

    It seems like this is enabled by going to Channels > Web Widget (Classic) > and then turning on "Article Recommendations".

    My questions is what prevents the flow builder mode from becoming active?

    Right now it appears as though I have messaging enabled and I see flow builder appears to be active which we do not want yet until more features are added such as the ability to allow users to select different channels, pays attention to agent availability and business hours. 

    0
  • Brenda Cardinez

    Hi Toni,

    Once this feature is activated, then it will be available during your operating and offline hours. The Answer Bot will still be enabled before offering the contact channels that are activated on your widget settings. See https://support.zendesk.com/hc/en-us/articles/115009692388 for activating components in your chat widget.

    Hey Jon,

    I'm going to bring this into a ticket so we can look into this further with you. You'll receive an email shortly stating your ticket has been created. :)

    0
  • Crystal Chenier

    Hello,

     

    I am having trouble with my AnswerBot generating articles when someone types a search. My AnswerBot starts over when I enter keywords instead of generating a article. Any suggestions on how to change this?

    0
  • alexandria.gazzillo

    Is there a way to edit the script and flow of the Answer Bot with Help Center article recommendations? 

    0
  • Dane
    Zendesk Engineering
    Hi Alexandria,

    You can try to use helpCenter:setSuggestions.
    0
  • Luis Pozo

    I enabled the Article Recommendations and the chat bot returns

    ' I couldn't find any relevant articles. You can ask another question.'

    It does not matter what I search for it does not work. The web widget is in a local env but If I go to the Help Center it work just fine? Could it be a setting that's off? Authentication issue?

     
     
    1
  • Christine
    Zendesk Engineering
    Hi Luis,
     
    Is your Help Center set to public or do you only allow signed-in users to access the articles? If so, please try to sign in to the help center as an end-user before testing the article recommendations. Most likely it is due to authentication if your Help Center is restricted.
    0
  • Luis Pozo

    Is it possible for you to write a step by step guide to check every checkbox? I have tried everything and can’t seem to figure this out. How would I sign in as an end user? Thank you ahead of time Christine :)

    0
  • Christine
    Zendesk Engineering
    Hi Luis,

    You can sign up for an end-user account using a different/personal email address that you can use for testing on your help center.
    0
  • Luis Pozo

    UPDATE - Created a dummy account as an end-user.. In the Help Center when I make a query i get the same issue as my personal account. Hopefully that gives you more context in what i should do next..? 

     

    0
  • Christine
    Zendesk Engineering
    Hi Luis,

    Kindly raise a ticket with our support team so we can further investigate why the widget is not suggesting articles. See Contacting Zendesk Customer Support from within your product. Thanks!
     
    0
  • shelley

    Is there a way to request the customers name & email address before the client can ask the Answer Bot a question?

    I have noticed that if the customers asks a question the Solved Ticket Requester is Unknown (Answer Bot). Therefore it doesn't link to the customers profile as an interaction.

     

     

     

     

    0
  • Dane
    Zendesk Engineering
    Hi Shelley,

    As it turns out, you cannot modify this behavior of the Classic widget. However, you can also look into the option of authenticating your users so that it will show the name of their user in Zendesk. For more information, please refer to Enabling authenticated visitors in Web Widget (Classic).
     
    0
  • shelley

    Thanks Dane, from my understanding end users would have to sign-in as part of the authenticating process, is that right?
    If so, I feel our users may find this tedious to do.

    0
  • Dane
    Zendesk Engineering
    Yes, you care correct. It's also the same for Messaging and Flow Builder where the name and email will be asked before transferring to an agent.
    1
  • Thomas verbrugghe

    Hello
    I saw "To enable Answer Bot for the Web Widget" to enable Answer Bot.
    However, I don't see the Answer Bot toggle in my account.

    It was there before but now it disappeared..

    0
  • Anne Ronalter
    Zendesk Customer Care
    Hello Thomas,

    in this case, please open a ticket with Zendesk Support, so that we can take a closer look at this issue.
    0
  • Odysseas Spanoudakis

    In Channels I do not see the option Classic > Web Widget.

     

    0
  • Viktor Osetrov
    Zendesk Customer Care
    Hello Odysseas,

    Could you please use the following URL path:
    https://{{YourSubdomain}}.zendesk.com/admin/channels/classic/web-widget
    Please change {{YourSubdomain}}to your subdomain address. 

    Hope it helps
    0

Please sign in to leave a comment.

Powered by Zendesk