Issue
When I try to make changes to my Salesforce sync settings for account, contact or ticket syncs, the Save button doesn't work. I'm not seeing any error message, but when I click the button, nothing happens. How can I fix this?
Cause
This can happen if a mapped field has been removed. This is what the error looks like in the interface. You'll get this error if the previously-mapped field is inactive or has been deleted. Select another field or delete this mapping.
There may be multiple fields impacted by the issue. This incorrect mapping can occur if a field is deactivated or deleted while while still mapped in the integration settings.
Resolution
Incorrectly mapped fields must be removed by mapping some other field on top of it. This other mapping can immediately removed:
If there are multiple incorrectly mapped fields, map all of them before clicking the Save button. If you click that button and nothing happens, perform a hard refresh of the page and retry.