如果您遇到电邮问题或有以下行为,请参阅:
- Zendesk Support发送或接收的电邮未送达
- 您收不到发送给终端用户或来自终端用户的电邮
- 电邮不会创建工单
- 电邮被检测为垃圾邮件
本文章介绍了这些问题:
未收到客户电邮,工单未创建或更新
解决不是从电邮创建的工单:
第 1 步:验证终端用户联系了哪个电邮地址
解决收到电邮后缺失的工单或评论的步骤:
- 让发件人向您发送电邮的副本
- 确保客服电邮地址显示在您的电邮渠道中
第 2 步:验证客服电邮地址的转发状态
如果您使用自定义电邮域名:
- 检查您的电邮地址在电邮渠道中的转发状态
- 要修复错误,请参阅如何修复转发检查失败错误。
如果您使用 Google 连接器但连接失败,请重新连接 Gmail 帐户,并按照 Google 身份验证提示进行操作。
如果您使用的是标准 Gmail 转发,请确认 Gmail 会将新到的消息转发到您的 Zendesk客服电邮地址。然后返回 Zendesk 并选择验证转发。
如果您使用外部电邮地址,请让您的电邮管理员确认是否已正确配置转发。Zendesk 可能最多需要 48 小时才能识别对转发设置的更改。
如果正常流量可以转发,但客服电邮地址未验证,请确认转发服务是否移除了 Zendesk 所需的电邮标头。
第 3 步:验证被阻止工单视图
解决来自未创建工单的客户的消息:
恢复电邮时,则表示您通知垃圾邮件过滤器该电邮是合法的。此操作的作用类似于电邮中的“不是垃圾邮件”或“不是垃圾邮件”按钮。您可能需要恢复一些电邮。系统会逐渐学习并根据模式允许合法电邮。
如果您的终端用户没有正确配置发件人策略框架 (SPF)、DKIM (DomainKeys Identified Mail) 或基于域的消息认证、报告与一致性协议(Domain-based Message Authentication, Reporting & Conformance,简称 DMARC)设置的电邮提供商,则增强的发件人身份验证设置可能将其电邮标为垃圾邮件。
其他原因也可能导致电邮发送问题。要进一步排除故障,请参阅:
第 4 步:检查您的Support电邮地址
确保客户联系的是您电邮渠道中列出的标准Support电邮地址。Zendesk 不Support电邮别名、分发列表或 Google Groups 作为Support电邮地址,这些地址可能导致发送问题。
如果电邮是发送到别名或组地址,请让客户重新发送到标准客服电邮地址。
第 5 步:检查工单是否隐藏在您的帐户中
如果工单存在但未显示在视图中,请检查视图条件。视图仅显示匹配所有必要条件的工单。另请检查工单是否已分配给您可以访问的组。
如果工单似乎已更新,但客户回复不可见,客户可能是在电邮定界符下方回复。在这种情况下,回复可以更新工单,但不会显示为可见评论。
客户收不到专员或团队发送的电邮或发出的回复
解决终端用户未收到专员电邮的情况:
第 1 步:检查电邮发送状态
第 2 步:验证工单中触发器是否会发送电邮
如果终端用户未收到电邮,可能是因为触发器未发送电邮。触发器对于 Zendesk Support 中的通讯和电邮至关重要。标题中以通知请求者开头的默认触发器不得取消激活。
确保触发器发送电邮的步骤:
- 在工单 URL 末尾添加
/events,打开受影响的工单活动日志 - 在专员留下的评论下,检查触发器是否发送了电邮
如果工单中不显示触发器,管理触发器:
第 3 步:验证默认通知触发器条件
通知客户的默认触发器应处于活跃的状态,并满足以下条件。
将评论更新通知请求者和抄送
- 在满足所有以下条件下:
Ticket > Ticket | Is | Updated和Ticket > Comment | Is | Public - 在“操作”下:
将新建主动式工单通知请求者
- 在满足所有以下条件下:
Ticket > Ticket | Is | Created,Ticket > Privacy | Is | Ticket has public comments、和Ticket details > Current user | Is | (agent) - 在“操作”下:
另请确保电邮通知正文至少包含一个占位符。如果没有占位符,电邮将不会发送。
第 3 步:验证电邮转发
如果触发器发送电邮,并且您使用自己的电邮域名,验证电邮转发:
- 检查相应电邮地址在电邮渠道中的转发状态
- 确保没有出现转发错误。如果出现错误,请参阅如何解决转发检查失败错误。
如果您使用 Google 连接器,但转发检查失败,请重新连接 Gmail 帐户,并按照 Google 身份验证提示进行操作。
如果您使用的是标准 Gmail 转发,请确认 Gmail 已将消息转发到 Zendesk客服电邮地址,然后选择在 Zendesk 中验证转发。
如果您使用外部电邮提供商,请让您的电邮管理员确认是否已启用转发,以及未移除必要的电邮标头。
第 4 步:验证 SPF 记录
SPF 记录允许 Zendesk 代表您发送电邮。如果您的域名中没有包含 Zendesk 的 SPF 记录,收件人可能会阻止从 Zendesk 发送的电邮。
- 检查相应电邮地址在电邮渠道中的 SPF
- 检查您域名的 SPF 记录,例如
example.com,使用MxToolbox等外部工具 - 如果
include:mail.zendesk.com您的域名没有显示 ,或者您的 SPF 返回错误,客户可能收不到您的电邮
您的域名只能有一条 SPF 记录。如果您使用多个电邮服务,请将其合并到一条包含所有必需来源的 SPF 记录中。
常见的 SPF 问题包括重复的记录、无效的语法、不受支持的 IP 地址、超过 10 个 DNS 查找、扁平化的 SPF 记录,以及 DNS 传播延迟。进行更改后,最多需要 48 小时才能验证记录。
要解决错误,请联系您的域名管理员,编辑现有的 TXT 记录以添加include:mail.zendesk.com。
管理员请参阅以下文章:
第 5 步:验证 DKIM 签名
此步骤不是强制执行的,但强烈建议执行。
- 将这两个 Zendesk 域名密钥添加到电邮域名的 DNS 记录中
- 在 Zendesk 中激活数字签名请参阅使用 DKIM 对电邮进行数字签名。
要确认您是否已正确将记录添加到域名,请参阅如何知道 DKIM 记录是否已正确配置?
第 6 步:验证 DMARC 配置
DMARC 与 SPF 和 DKIM 协同工作,以保护您的域名并确保客户送达您的电邮。如果没有 DMARC,许多严格的电邮提供商可能会筛选或拒绝您的电邮。
请咨询您的域名管理员,确保已为您的域名配置 DMARC 政策。
对于政策建议,最好从以下政策开始p=none以监测您的电邮流量。在验证所有合法电邮(包括从 Zendesk 发送的电邮)是否通过 SPF 和 DKIM 正确进行身份验证后,您可以迁移到更严格的政策:p=quarantine或p=reject。
第 7 步:验证收件人的状态
如果触发器发送电邮,而您域名的 SPF 记录包含Zendesk Support,则收件人服务器可能会阻止新到的电邮。您可能不会在被阻止工单视图中收到退回通知。
验证收件人状态的步骤:
- 联系收件人并注明被阻止电邮的详情
- 让收件人检查其垃圾邮件收件箱
- 如果电邮不在垃圾邮件中,请让收件人验证其服务器阻止您电邮的原因
- 询问收件人是否可更改设置,以接受专员今后发送的电邮
电邮发送取决于收件人中继服务器。每家公司使用的筛选和设置各不相同,Zendesk 客户支持无法控制。
翻译免责声明:本文章使用自动翻译软件翻译,以便您了解基本内容。 我们已采取合理措施提供准确翻译,但不保证翻译准确性
如对翻译准确性有任何疑问,请以文章的英语版本为准。